Perfect Server Fedora 9

Discussion in 'HOWTO-Related Questions' started by a.s.techgeek, Sep 13, 2008.

  1. a.s.techgeek

    a.s.techgeek New Member

    I wanted to say thanks to the author Falko for the tut, Perfect Server Fedora 9. Good tutorial, easy to follow, not too confusing.

    I have had a couple of minor problems, think maybe something I did. I did some searching on both Fedora Forums and this forum and found some information that touched base on my issues but not completely.

    I followed the tutorial the first, I didn't have much trouble until I got to Quota, Ruby, and ISPconfig. ISPConfig wouldn't install fully. When I rebooted it wouldn't mount the file system and would hang.

    When I started over, I got about as far as disabling SElinux and upon reboot, loading "sendmail" took longer than normal to load. When I was finally able to login, it was almost like my machine was bogged down. It seemed odd, the system is using a AMD Athlon 64 with a gig of ram.

    Great tutorial and describes the exact system I need. I have hopes to set up a small network for our office with all the features this tutorial has.

    I live in a rural area without broadband, our office been in talks with an major ISP provider. With hopes of becoming hosting multiple servers, and bringing broadband to the area. I would really like to set this kind of system up; clone it and install on multiple machines with maybe minimal configuration on varying systems.

    I am in the process of a third attempt and will more than likely be posting further issues.
  2. falko

    falko Super Moderator ISPConfig Developer

    That sounds as if the internet connection or the DNS resolution are not working. What's in /etc/resolv.conf?
  3. a.s.techgeek

    a.s.techgeek New Member

    I have once again started over, have got all the packages installed and was successful in getting ISPconfig to install with no errors.

    When I reboot the system now, it starts apache and asks for my pass phrase I enter the pass phrase and then a screen loads, with a blank menu bar. There is no usual login screen nothing. I have read other posts where there is an modification for "any shell" and see if that fixes my problem
    Last edited: Sep 15, 2008
  4. a.s.techgeek

    a.s.techgeek New Member

    Is there a way to get to the /etc/shells file and edit those lines, using a live cd?
    I have tried mounting the drive into the /mnt file on the live cd with no luck. I am not that good with remembering all the commands and am at a loss really now wanting to start over. If I do I think I will try and edit that file before I actually shut the machine down after installing ispconfig.
  5. falko

    falko Super Moderator ISPConfig Developer

    Press ALT + F2 to get to the console. You can then edit /etc/shells with vi:
    vi /etc/shells
    Reboot the system afterwards.
  6. torodriver

    torodriver New Member

    Another Fan With Questions

    I too am working on a Web server based on your article. I have two questions, one, I set-up a Web server just by luck and with help from articles like yours on Fedora 2. I tried to do the same thing with Fedora 9 and ran into problems. That is how I came across your article in the first place. I cannot access the Web server from the Internet. The new install has the same IP address and host name, but it wont respond to requests. This is the error message I get on boot up.

    Starting httpd: (98) address already in use: make_sock: could not bind to address [::]:80

    The server is behind a router but has forwarding allowed for the severs IP address. I have changed nothing in my network except the server OS

    Second question. when I run mysqladmin for -h I get the following error.

    mysqladmin: connect to server at '' failed
    error: 'Host '' is not allowed to connect to this MySQL server'

    I had no trouble with the root password, just the host/root shot me the above error.

    my hosts file looks like this.

    # Do not remove the following line, or various programs
    # that require network functionality will fail. localhost.localdomain localhost server1
    ::1 localhost6.localdomain6 localhost6

    Hope I am not jumping on the other posters toes, just want to get my server up and running again. I will continue with the tutorial and check back.

    Thanks in advance...

  7. torodriver

    torodriver New Member

    Fixed 1 problem

    I corrected the issue with the (98) address already in use.

    but now I want to add on more question. instead of, can I go with, or does it matter what I name the server. And I still am looking for a fix for MySQL not wanting to accept host passwords. In fact this is the error I just received.

    # mysqladmin -h -u root password ********
    mysqladmin: connect to server at '' failed
    error: 'Host '' is not allowed to connect to this MySQL server'

    Other than that little issue I am on page five and moving along.

  8. falko

    falko Super Moderator ISPConfig Developer


    Take a look at chapter 8 on (beginning with the "As you've seen in the netstat output, MySQL is not only listening on localhost" part) to see how you can fix this.
  9. torodriver

    torodriver New Member

    MySQL is fixed

    That did the trick, I am now going to attempt ISPConfig. Great tutorial, it makes doing it right easy.

Share This Page