Perfect Server Fedora 10 User Authentication Fails

Discussion in 'HOWTO-Related Questions' started by Buford, Jul 10, 2009.

  1. Buford

    Buford New Member

    hello again.

    Here's my situation. I was able to do the steps in the guide without any problems. I installed squirrelmail and tried to open my mails from a web browser but i got this error.

    ERROR: Connection dropped by IMAP server.

    looking at /var/log/maillog, i got this...

    Jul 10 15:53:20 mail dovecot: imap-login: Internal login failure (auth failed, 1 attempts): user=<[email protected]>, method=PLAIN, rip=, lip=, secured

    I want to use the Standard Unix User Database since i only administer one domain. I made a custom dovecot password file using {PLAIN} as my scheme, as seen above. I did this because dovecot won't authenticate using Unix passwd file.

    Moreover, If i use thunderbird, I get a Authentication Failed Error.

    I'm betting that it's the scheme that I used that's causing the problem...
    Is this correct? if so, then what is the scheme that I should use?
    If this is wrong, could you please direct me to what I should do next?

    Thanks in advance!!!
  2. falko

    falko Super Moderator ISPConfig Developer

    Which tutorial exactly (URL) did you use?
  3. Buford

    Buford New Member

    Solved it but got a new problem

    I solved this by creating a custom password file. It seems dovecot could not retrieve the password file from /etc/passwd so i created a /etc/dovecot.users with the following syntax. I got this from another site. sorry i forgot the actual URL for it due to my excitement.



    restarted postfix, saslauthd, dovecot and httpd

    Everything works in Thunderbird. I can download and send emails with it. But get this error in Squirrelmail.

    You must be logged in to access this page.

    I tried everything I googled but not one solved it.

    btw falko, this is the guide i followed.

    i only followed the steps for email and skipped the other services...
  4. Buford

    Buford New Member

    Mail Clients OK but not in webmail

    Like I said, it works in thunderbird. I also just tried it in outlook and everything works fine. I am able to send and receive email to and from my Yahoo Mail account and vice-versa.

    My only problem is that i can't login to Squirrelmail(webmail). This is what I get at the maillog.

    Jul 14 12:12:35 mail dovecot: auth(default): passwd-file(my.account, lookup: user=my.account file=/etc/postfix/dovecot.users
    Jul 14 12:12:35 mail dovecot: auth(default): client out: OK#0111#011user=my.account
    Jul 14 12:12:35 mail dovecot: auth(default): passwd(my.account, lookup
    Jul 14 12:12:35 mail dovecot: auth(default): master out: USER#0111#011my.account#011system_user=my.account#011uid=500#011gid=500#011home=/home/my.account
    Jul 14 12:12:35 mail dovecot: imap-login: Login: user=<my.account>, method=PLAIN, rip=, lip=, secured
    Jul 14 12:12:35 mail dovecot: IMAP(my.account): Disconnected: Logged out bytes=44/298

    As you can see, IMAP immediately logs me out right after authentication. I don't understand why this is happening...
  5. falko

    falko Super Moderator ISPConfig Developer

    Do you use the SquirrelMail package from the ISPConfig web site? If so, you need to log in woth the email address instead of the username.
  6. Buford

    Buford New Member

    Nope. I am using the rpm package from the fedora repos. When i use the email address, I get "Unknown username or Wrong Password" error.

    I don't have ISPConfig installed on my server.
    Last edited: Jul 14, 2009
  7. Buford

    Buford New Member

    my dovecot.conf

    this is my dovecot.conf

    most of the other options are set to default

    protocols = imap imaps pop3 pop3s
    disable_plaintext_auth = no
    mail_location = maildir:~/Maildir
    protocol imap {
    imap_client_workarounds = delay-newmail outlook-idle netscape-eoh
    protocol pop3 {
    pop3_uidl_format = %08Xu%08Xv
    pop3_client_workarounds = outlook-no-nuls oe-ns-eoh

    protocol managesieve {
    auth_debug_passwords = yes
    auth default {
    mechanisms = plain
    passdb passwd-file {
    args = /etc/postfix/dovecot.users
    userdb passwd {
    user = root
    dict {
    plugin {
  8. falko

    falko Super Moderator ISPConfig Developer

    How exactly did you set up your email accounts?
  9. Buford

    Buford New Member

    Solved it!

    I was able to solve it. It was never a postfix/dovecot/squirrelmail problem. I checked my logs in /var/log/httpd_error_log and saw this:

    Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0

    It was a permission error. When I checked the owner of /var/lib/php/session, it belonged to 'nobody'. I changed the ownership to 'apache'a nd everything worked!!!

    I changed the ownership to 'nobody' as a solution stated in this thread.

    but this did not help me at all. by doing the command,

    chown apache:apache /var/lib/php/session

    everything worked!!!!

    Thanks for all the ideas and the great tutorial falko!!!


Share This Page