Perfect Server - Fedora 10 - Page 2

Discussion in 'Server Operation' started by mdrain18, Mar 23, 2009.

  1. mdrain18

    mdrain18 New Member

    Right after the installation I rebooted but the text mode set-up utility did not run. Now I did not think it was that big of a deal considering you can disable the firewall on the UI, I also checked the Network/DNS Config and it was all set properly. My real question comes after that, when you have to change /ect/hosts. I know what I have to change it to but I am having trouble changing it. I manually went to the file and tried to change it there but it says I do not have permission to change it because I am not the owner. I also tried running it through terminal as root but still same permission problem. I know I am missing something, I'm just not seeing it. I am also having the same permission problem with disabling the SELinux.

    Reading over it again right now, I just wanted to mention that I did use terminal with the vi /etc/hosts but still could not change anything.

    Not sure what I did wrong. Very sorry that I had to bother you with the questions, but I just could not find anything online.

    Thank you and hope to hear from you soon.
     
  2. falko

    falko Super Moderator

    Did you install a desktop on the server?

    Anyway, open a terminal, then become root:
    Code:
    su
    and then run
    Code:
    vi /etc/hosts
     
  3. mdrain18

    mdrain18 New Member

    did that and it posted the file as it was but i could not change it...so i then accessed the file directly and tried changing it there but i did not have permission to do so because i did not create it.
     
  4. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -l /etc/hosts
    ?
     
: falko

Share This Page