Perfect Server Fedora 10 - make sure mod_rewrite is enabled and working

Discussion in 'Server Operation' started by bryand1, May 3, 2009.

  1. bryand1

    bryand1 New Member

    Hello,

    I recently installed Fedora 10 on my new server using the Perfect Server tutorial and the server is working perfectly!!

    I have a shopping cart website that I moved over from another host (copied database and all files), but none of my links will work because I think my mod_rewrite is not active.

    I searched google and there are a lot of different answers. I think this is an easy problem to solve. I can see in my apache modules that the mod_rewrite.so is already there, so how can I get it to load?

    Thanks for your help!

    -Bryan
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    httpd -M
    ?
     
  3. bryand1

    bryand1 New Member

    It lists all of the modules.

    Code:
    ...
    rewrite_module (shared)
    ...
    
    Does this mean it is enabled?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, it's enabled.
     
  5. mun mun

    mun mun New Member

    I have also faced the problem. Solved it by changing the line 'AllowOverride none' to 'AllowOverride All' in the <Directory "/var/www/html"> section of httpd.conf file.
     

Share This Page