Perfect Server Edgy - install courier-authdaemon

Discussion in 'HOWTO-Related Questions' started by yunus89115, Mar 10, 2007.

  1. yunus89115

    yunus89115 New Member

    I am on page 5 of the Perfect server HowTo and when I get to the step

    Run this to install Courier-IMAP/Courier-IMAP-SSL (for IMAPs on port 993) and Courier-POP3/Courier-POP3-SSL (for POP3s on port 995):
    I get a failure message saying
    Any thoughts or workarounds that I could use? I tried just not choosing the authdaemon package but none of the other courier packages will work either.

    Just for background purposes I am an expert in Windows but a total novice in Linux so dont be afraid to spell something out or talk to me like im in first grade because as far as Linux servers are concerned I am in first grade.

    Thanks for all your help!
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    What's in the file
  3. yunus89115

    yunus89115 New Member

    sources.list contains

    I just tried uncommenting all the sources and then rebooting but got the same error message.
    Last edited: Mar 11, 2007
  4. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Courier resides in the universe repository. Uncomment (remove the # sign) of the lines with universe (4 lines). Then retry.
  5. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    apt-get update && apt-get upgrade
    after uncommenting. Rebooting has no effect whatsoever. It's not sw from Redm....
  6. yunus89115

    yunus89115 New Member

    Thanks, got past that and finished up the installation in no time.
  7. yunus89115

    yunus89115 New Member

    I've got another question about the server. I can send email just fine but I cant seem to access email. When I send it to the address it does not kick back instantly which it did before I fixed my mx record but I get an error involving sending the password.

    I know this is just a setting in a file but im stuck.

  8. falko

    falko Super Moderator ISPConfig Developer

    Did you configure Postfix to deliver emails to Maildir instead of mbox?
  9. yunus89115

    yunus89115 New Member

    I have run the following commands
    I tried to check mail before and after I ran those commands and neither worked.

    I thought at first mail was not failing but I had a dns registration error so it was waiting a long time before sending the failures but now if I send an email to my domain it immediately comes back with a failure

    When I try to check the mail on the linux server I get the Unable to connect to POP server server.*****.com Error sending password: Broken pipe

    ***** is in place of my domain


    found this post
    it solved my problems

    for now... :)
    Last edited: Mar 16, 2007

Share This Page