Perfect Server (Debian Squeeze/ISPConfig3) working not so perfect

Discussion in 'HOWTO-Related Questions' started by M.H.W. Smits, Aug 8, 2011.

  1. M.H.W. Smits

    M.H.W. Smits New Member

    Still Access Denied...
  2. Mark_NL

    Mark_NL Member

    ok, this might take a while ..

    if you want i can have a look at your server.
    but i need shell access to it.

    contact me on skype or pm me
  3. M.H.W. Smits

    M.H.W. Smits New Member

    Well, as I said I am persistent (and pig-headed :rolleyes:). I started over once again, but without setting up RAID.

    The output after installation of ISPConfig 3 was now the same as in the Perfect Server Guide: this time restarting bind9 just before completing the installation (this didn't happen with the previous installs).

    However, during boot I still receive the Apache2 "MySQL Connection problem" message.

    In the Apache error log I found the same error messages as before:
    "child pid 21639 exit signal Segmentation fault" and "DBI connect('database=dbispconfig;host=localhost:3306','ispconfig',...) failed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) at /usr/local/ispconfig/server/scripts/vlogger line 257".

    I can login to MySQL with both the root user and ISPConfig credentials, whereas I was unable to login with ISPConfig credentials with my previous install.

    Browsing to the server gives the well-known "It works page", Squirrelmail login page shows when browsing to /webmail, but browsing to the ISPConfig login still shows the XML source code. I have also tried to open in other browsers, and Google Chrome came up with this error description: "This XML file does not appear to have any style information associated with it."

    Hopefully I am a (small) step closer to a working system...?
  4. jfried

    jfried New Member

    Have you tried replacing "localhost" with "" in your ispconfig config file? Because, if you use "localhost" php try to connect to the socket (and it complains the he can't find the socket file).
  5. M.H.W. Smits

    M.H.W. Smits New Member

    I tried this during my last install, but it didn't help.

    Also, I believe the problem is not in ISPConfig, because a) Apache2 gives a MySQL connection error during boot, which probably also causes the problems for ISPConfig and b) since I have followed all steps from the Perfect Setup Guide, localhost in the ISPConfig config file shouldn't be a problem, since everybody using this setup should then have the same connection problem.
  6. M.H.W. Smits

    M.H.W. Smits New Member

    And it works...


    Mark has taken a look on my server, but couldn't test the ISPConfig login because remote access on port 8080 was blocked by my brand new modem (I had made a rule redirecting port 8080 to my server, but it had forgotten some more rules during the weekend...:confused:)

    In the end, Mark said he did nothing else than looking around in configuration files, and now everything works...!?

    No idea what happened to the Apache2 MySQL connection problem on the way...

    Thank you Mark for taking a look, apparently it was convincing enough for my server to start working...:D

    Of course also thanks to all other users who gave their input during my quest to get the server working!
    Last edited: Aug 15, 2011
  7. Mark_NL

    Mark_NL Member

    hehe, yeah i did nothing else then look at the config and log files with a face like this:


    that did the trick :)

Share This Page