Perfect Server (Debian Squeeze/ISPConfig3) working not so perfect

Discussion in 'HOWTO-Related Questions' started by M.H.W. Smits, Aug 8, 2011.

  1. M.H.W. Smits

    M.H.W. Smits New Member

    This weekend I have installed Debian Squeeze and ISPConfig3 guided by the Perfect Setup Howto. During the setup I had no problems, but after installing ISPConfig3 i can't open the login screen. All I get to see is this:

    <SOAP-ENV:Envelope xmlns:SOAP-ENV="" xmlns:SOAP-ENC="" xmlns:xsi="" xmlns:xsd="" xmlns:ifx="urn:dsl_api">
    <SOAP-ENV:Fault SOAP-ENV:encodingStyle="">
    accept failed in soap_accept()
    After reviewing all installation steps I found nothing wrong, but wanting to be sure I started from the beginning again. With the same result however.

    I found the following:
    • during the installation of ISPConfig, during configuration it says configuring BIND, but just before completion of the installation according to the Howto it has to restart BIND, after restarting the ftp server. This doesn't happen at my pc.
    • during boot i get the message Starting web server: Apache2MySQL Connection Problem

    Apparently, I have a Apache problem, but having double-checked all my steps during installation, I can't find where it went wrong.

    Anybody have an idea?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of the command:

    netstat -tap

    and which exact URL did you use to access ISPConfig?
  3. M.H.W. Smits

    M.H.W. Smits New Member


    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State                                                                                                             PID/Program name
    tcp        0      0 *:sunrpc                *:*                     LISTEN                                                                                                            1021/portmap
    tcp        0      0 *:ftp                   *:*                     LISTEN                                                                                                            2248/pure-ftpd (SER
    tcp        0      0 server1.mssweb.n:domain *:*                     LISTEN                                                                                                            1387/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN                                                                                                            1387/named
    tcp        0      0 *:ssh                   *:*                     LISTEN                                                                                                            2012/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN                                                                                                            2252/master
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN                                                                                                            1387/named
    tcp        0      0 *:34269                 *:*                     LISTEN                                                                                                            1033/rpc.statd
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN                                                                                                            1530/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN                                                                                                            2252/master
    tcp        0      0 *:mysql                 *:*                     LISTEN                                                                                                            2044/mysqld
    tcp        0      0 localhost.localdo:41774 localhost.localdoma:www TIME_WAIT                                                                                                         -
    tcp        0      0 localhost.localdo:58595 localhost.localdoma:ftp TIME_WAIT                                                                                                         -
    tcp        0      0 localhost.localdo:35827 localhost.locald:domain TIME_WAIT                                                                                                         -
    tcp        0     52   router.home:51427       ESTABLISHED                                                                                                       2995/0
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN                                                                                                            1713/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN                                                                                                            1683/couriertcpd
    tcp6       0      0 [::]:http-alt           [::]:*                  LISTEN                                                                                                            1550/apache2
    tcp6       0      0 [::]:www                [::]:*                  LISTEN                                                                                                            1550/apache2
    tcp6       0      0 [::]:tproxy             [::]:*                  LISTEN                                                                                                            1550/apache2
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN                                                                                                            2248/pure-ftpd (SER
    tcp6       0      0 [::]:domain             [::]:*                  LISTEN                                                                                                            1387/named
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN                                                                                                            2012/sshd
    tcp6       0      0 ip6-localhost:953       [::]:*                  LISTEN                                                                                                            1387/named
    tcp6       0      0 [::]:https              [::]:*                  LISTEN                                                                                                            1550/apache2
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN                                                                                                            1701/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN                                                                                                            1727/couriertcpd
    To access ISPConfig I have tried:
    and ip-address:8080/

    The first two give a slightly different output, the first giving faultcode "SOAP-ENV: Client" and faultstring "HTTP GET method not implemented", the second giving faultcode "SOAP-ENV: Server", faultcode "Timeout" and detail "accept failed in soap_accept()". Using the ip-adress gives the same result as the latter.
  4. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in Apache's error log?

    Is there any other vhost running on port 8080 (besides the ISPConfig vhost)?
  5. M.H.W. Smits

    M.H.W. Smits New Member

    Hi Falko,

    There are no other vhosts running on this server. It's completely setup according to your Perfect Setup guide, the only difference being that I installed it on a RAID 1 system.

    There's only one error message in the apache2 error.log, but it occurs multiple times:

    "child pid 21669 exit signal Segmentation fault (11)"

    All other messages are "resuming normal operations" notices.

    Hope this information helps.


  6. falko

    falko Super Moderator ISPConfig Developer

    Is this a physical server or a virtual machine? If you use OpenVZ, what's the output of
    cat /proc/user_beancounters
  7. M.H.W. Smits

    M.H.W. Smits New Member

    This is a physical server, not a virtual machine.
  8. falko

    falko Super Moderator ISPConfig Developer

    Hm, thne I'm running out of ideas... :(
  9. M.H.W. Smits

    M.H.W. Smits New Member

    Thank god! When I stumbled upon this problem I thought I was getting crazy and overlooking a very obvious solution. But since you are also running out of ideas, the problem clearly isn't that simple...

    Unfortunately, this also means there is no quick solution :(

    Guess I will have to start over once again. I will persevere...
  10. Mark_NL

    Mark_NL New Member

    What does this say?

    apache2ctl -S
    you could try reinstalling ispconfig
    (make sure you have
    go to the install dir of ispconfig and run:
    php uninstall.php
    php install.php
    if that fails, you can hand out shell access so one of us can have a look. A fresh pair of eyes often helps :)
  11. jfried

    jfried New Member

    You could try to start the apache in debug mode (-X flag). this will start only one worker and does not detach from the console. please provide the output.

    Could you also please provide a coredump file? (see this link how to configure apache to create one

    I don't know the internals of isp config, but perhaps there is a problem with one of the php modules (the compiled ones)


  12. M.H.W. Smits

    M.H.W. Smits New Member


    I have just found a new error in the Apache2 error.log which appeared for the first time today:

    DBI connect('database=dbispconfig;host=localhost:3306','ispconfig',...) failed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) at /usr/local/ispconfig/server/scripts/vlogger line 257
    Output of apache2ctl status:

    Apache Server Status for localhost
    Server Version: Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/
        5.3.3-7+squeeze3 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16)
        mod_ssl/2.2.16 OpenSSL/0.9.8o
    Server Built: Mar 22 2011 21:14:10
    Current Time: Thursday, 11-Aug-2011 14:20:10 CEST
    Restart Time: Thursday, 11-Aug-2011 14:14:06 CEST
    Parent Server Generation: 1
    Server uptime: 6 minutes 3 seconds
    Total accesses: 0 - Total Traffic: 0 kB
    CPU Usage: u0 s0 cu0 cs0
    0 requests/sec - 0 B/second -
    1 requests currently being processed, 4 idle workers
    Scoreboard Key:
    "_" Waiting for Connection, "S" Starting up, "R" Reading Request,
    "W" Sending Reply, "K" Keepalive (read), "D" DNS Lookup,
    "C" Closing connection, "L" Logging, "G" Gracefully finishing,
    "I" Idle cleanup of worker, "." Open slot with no current process
    A reinstall of ISPConfig didn't solve the problem.


    (98)Address already in use: make_sock: could not bind to address [::]:80
    (98)Address already in use: make_sock: could not bind to address
    no listening sockets available, shutting down
    Unable to open logs
    Action '-X' failed.
    The Apache error log may have more information.
    No more info in the error log though.

    I will post a coredump later.

  13. Mark_NL

    Mark_NL New Member

    show me: apache2ctl -S
  14. jfried

    jfried New Member

    Just configure your database connection to use the ip "" and not "localhost". Then the connection should work. (if you have sufficient rights to access it)
  15. M.H.W. Smits

    M.H.W. Smits New Member

    apache2ctl -S output:

    VirtualHost configuration:
    wildcard NameVirtualHosts and _default_ servers:
    _default_:8081 (/etc/apache2/sites-enabled/000-apps.vhost:10)
    *:8080                 is a NameVirtualHost
             default server (/etc/apache2/sites-enabled/000-ispconfig.vhost:10)
             port 8080 namevhost (/etc/apache2/sites-enabled/000-ispconfig.vhost:10)
    *:80                   is a NameVirtualHost
             default server (/etc/apache2/sites-enabled/000-default:1)
             port 80 namevhost (/etc/apache2/sites-enabled/000-default:1)
    Syntax OK
  16. Mark_NL

    Mark_NL New Member

  17. M.H.W. Smits

    M.H.W. Smits New Member

    Yes, I know. The Squirrelmail login also works. But ISPConfig3 doesn't work.

    Judging on the error log, problem must be somewhere in the MySQL and/or Apache2 configuration.
  18. Mark_NL

    Mark_NL New Member

    Try logging in with ispconfig credentials from cli with:
    mysql -u ispconfig -p
    And enter the password that you can find in the file:
  19. M.H.W. Smits

    M.H.W. Smits New Member


    Doesn't work...:

    ERROR 1045 (28000): Access denied for user 'ispconfig'@'localhost' (using password: YES)
  20. Mark_NL

    Mark_NL New Member

    Then there's your problem :)

    Get the password again:
    grep -i db_password /usr/local/ispconfig/interface/lib/
    Set the password:
    mysql -u root -p
    mysql> update mysql.user set password=PASSWORD("<PASSWORD>") where User='ispconfig';
    mysql> flush privileges;
    mysql> quit

Share This Page