Perfect Server Debian, ISPConfig3 cant connect after applying firewall

Discussion in 'Installation/Configuration' started by Gigaquad, Mar 7, 2012.

  1. Gigaquad

    Gigaquad New Member

    {SOLVED} Perfect Server Debian, ISPConfig3 cant connect after applying firewall

    Hello everyone. I'm a stone cold newbie but I've learned alot since starting this tutorial. Thanks for such a wealth of info in one place!

    My problem is with the Perfect Server on Debian and ISPConfig 3. I was going thorough the next stage, Extending the Perfect Server on Debian Squeeze, and at the point where I add more ports to the firewall I add them as described in step 6: "Before changing a port to something else than the default, DON'T forget..."

    Well while there I noticed that the port I was using for ISPConfig (52044) wasn't listed so I added it too. Then I hit Save.
    All was well until I rebooted. Now I can access the sites, but I can't get to the ISPConfig control panel anymore.

    I've tried restarting Apache.
    I've removed the port 52044 from the ISPConfig database via phpmyadmin.
    I've chewed my fingernails and googled until my eyes goggled. :)

    So now I'm at a loss. Anyone have any ideas where I should look or what I should check?

    Last edited: Mar 9, 2012
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Stop the firewall:

    /etc/init.d/bastille-firewall stop

    2) Login to ispconfig and change the port.

    By the way, never change values in the ispconfig database directly. Your manual cahnges will be ignored as they are a invalid configuration transaction.
  3. Gigaquad

    Gigaquad New Member

    Thanks for the help! It worked great when the firewall was down, but when I re-enabled the firewall (/etc/init.d/bastille-firewall start) it wasn't accessible again.

    For some reason the ports aren't being accepted I think?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you added it as tcp port and not udp port and that you separated it with , from the other ports.
  5. Gigaquad

    Gigaquad New Member

    I verified that it's a TCP port and separated by a comma. Both are correct.

    Here's my list right now:

    Edited to add: I don't know why the 8081 has a space in the line above. It doesn't have one on my server and I even retyped it and it still shows a space.
    Last edited: Mar 9, 2012
  6. Gigaquad

    Gigaquad New Member

    I just did a little looking (thanks for the pointer to Bastille!) and my cfg file located here:


    did NOT have the updated firewall ports inside. It just had the default ones.
    Could this be a permissions issue?
    If so, how would I change it?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    It can be a issue with the way you entered the port numbers in ispconfig or the job could not be executed for other reasons.

    Please post a secreenshot of the port settings of the firewall in ispconfig and are there any jobs listed in the hobqueue in the ispconfig monitor?
  8. Gigaquad

    Gigaquad New Member

    Here's a SS

    There's nothing in the jobsqueue in ISPConfig.
  9. falko

    falko Super Moderator ISPConfig Developer

    Your screenshot shows a space between 80 and 81 as well. Please double-check.
  10. Gigaquad

    Gigaquad New Member

    You're right. Now, when I look right at it on the screen it shows no space. When I open it for editing it shows no space. But in the SS and in the paste it has a space.

    I copied them all into Notepad (to remove anything fancy) then copied them back. And guess what? It WORKED!

    I thought it might be a file permissions issue but I guess ISPConfig had a little "nothing" character in there in the 8081 port. How odd!

    It's worth noting that I never messed with this page prior to the above mentioned step 6.

    At any rate, it's perfect now. Thank you! Please mark this topic as {SOLVED}

    I'm really digging ISPConfig now too with all the playing around I've done. Except for that PHP_Basedirs issue. I'm still working on that one :)

Share This Page