Perfect Server Debian 9 with ISPConfig - Roundcube issue

Discussion in 'General' started by onastvar, May 15, 2019.

  1. onastvar

    onastvar Member

    I followed Perfect Server Debian 9 setup, tried to upgrade Roundcube to latest v1.39 now I see these issues in my log Roundcube does not load javascript, css, etc:

    Symbolic link not allowed or link target not accessible: /var/lib/roundcube/program
    Symbolic link not allowed or link target not accessible: /var/lib/roundcube/plugins/jqueryui
    Symbolic link not allowed or link target not accessible: /var/lib/roundcube/skins/larry

    I modified following:
    Options -Indexes
    to
    Options +FollowSymLinks
    in
    nano /etc/apache2/sites-available/ispconfig.conf
    <Directory />
    Options +FollowSymLinks
    AllowOverride None
    Require all denied
    </Directory>

    still same issue, please help!
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    There are security implications to that (ie. you just lowered your system security in some aspects).

    I don't use that version of roundcube, but if I were going to set it up on debian I would reference the v1.38 apache config from debian: https://sources.debian.org/src/roundcube/1.3.8+dfsg.1-2/debian/conf/apache.conf/ That will of course use debian paths and such, which you'll need to adjust according to how you installed it.
     
  3. onastvar

    onastvar Member

    Thanks @jesse Norrell.
    I restored Options -Indexes
    how can i install roundcube on my own not one from debian repo?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Create a website in ispconfig with php enabled, create a database user and database in ispconfig and then install roundcube into that website.
     
  5. onastvar

    onastvar Member

    Thanks @till.
    1) What domain name (under Clients > Domains) is recommended for new website (Sites) to be used for Roundcube application?
    2) I tried to add domain name ("ROUNDCUBE) but i get error "This domain-name is not allowed"
    3) If I setup roundcube in its own website, would it still be available under all domains (under domain.com/webmail), I have this line "Alias /webmail /var/lib/roundcube" in /etc/apache2/conf-enabled/roundcube.conf ?
     
    Last edited: May 15, 2019
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    1) That's up to you.
    2) First, domain names should be lowercase, then your domain is not an fqdn. A valid domain name would be e.g. roundcube.yourdomain.tld
    3) No, it is available under the domain name that you have chosen for the website.
     
  7. onastvar

    onastvar Member

    @till Thanks again for clarification!
    Regarding answer #3, how can I install the latest Roundcube and still have it available for each client's website? When I installed Perfect Server Debian 9 with ISPConfig - Roundcube 1.23 was working, after I tried to upgrade to Roundcube 1.39, it is not working anymore. How can I start over to at least go back to original setup of Roundcube per your tutorial?
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Is there a compelling reason to install Roundcube 1.39?
    If you use the Roundcube that comes with Debian Stretch, it works and the ISPConfig Roundcube plugins work with it also.
    If you really must have a later version of Roundcube, like @Jesse Norell already told, you have to do the modifications to original Roundcube that Debian project has done. Then you might get it working on Debian, but likely not. You can see what changes debian did by comparing the source code files provided by debian:
    Code:
        [roundcube_1.2.3+dfsg.1-4+deb9u3.dsc]
        [roundcube_1.2.3+dfsg.1.orig.tar.gz]
        [roundcube_1.2.3+dfsg.1-4+deb9u3.debian.tar.xz]
    
    There is also version 1.3.8 in Debian Testing, it might be easier to use that as base for your own effort, but since it is not backported to Debian Stretch I assume it is not easy to get it working on Stretch.
    By the way, you can see from changelog that Debian project has backported security fixes to the 1.2.3 version, so if you thought you need those they are already in the Debian Stretch version of Roundcube.
     
  9. onastvar

    onastvar Member

    Thanks @Taleman. How can i uninstall and reinstall roundcube v1.23 that comes with debian 9
     
  10. onastvar

    onastvar Member

    I was able to remove failed roundcube installation using the following steps:

    First, you need to find the extact package name from the list of installed packages using the command:
    dpkg --get-selections | grep -i roundcube
    Then, you can remove it using the commnand:
    apt-get remove <package name>
    Where <package name> is the name you got from the first command.

    Install roundcube debian package again per instruction from The Perfect Server - Debian 9 (Stretch) with Apache.
     
  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    apt-get remove does remove if you installed with apt-get. How did you install the other Roundcube version?
     
  12. onastvar

    onastvar Member

    After I reinstalled, I still see following errors in logs.

    Symbolic link not allowed or link target not accessible: /var/lib/roundcube/program
    Symbolic link not allowed or link target not accessible: /var/lib/roundcube/plugins/jqueryui
    Symbolic link not allowed or link target not accessible: /var/lib/roundcube/skins/larry


    When I login I don't see any emails, when I click on anything under Settings > Section nothing happens (right side pane is blank)
     
    Last edited: May 17, 2019
  13. onastvar

    onastvar Member

    I downloaded complete tar.gz from roundcube.net and ran install to target folder /var/lib/roundcube - had issues, opened up this thread.
     
  14. onastvar

    onastvar Member

    Update:
    I followed tutorial: RoundCube webmail installation on Debian 8 (Jessie) Update and successfully installed Roundcube 1.3.9 on Debian 9. Thanks all for help!

    I just got a little issue with ispconfig3_roundcube plugin
    When I'm in ROUNDCUBE > Settings > Account > General, I get

    Soap Error: The login is not allowed from my ip

    nano /opt/roundcube/plugins/ispconfig3_account/config/config.inc.php
    <?php
    $rcmail_config['identity_limit'] = false;
    $rcmail_config['remote_soap_user'] = 'roundcube';
    $rcmail_config['remote_soap_pass'] = 'my password';
    $rcmail_config['soap_url'] = 'https://server.mydomain.com:8080/remote/';
    $config['soap_validate_cert'] = false;
    ?>
     
    Last edited: May 18, 2019
  15. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  16. onastvar

    onastvar Member

    Fixed
    System > Remote User > roundcube (Remote Access checkbox wasn't ticked) after I did that, it works.

    nano /opt/roundcube/plugins/ispconfig3_account/config/config.inc.php
    <?php
    $config['identity_limit'] = false;
    $config['remote_soap_user'] = 'roundcubemail';
    $config['remote_soap_pass'] = 'my password';
    $config['soap_url'] = 'https://mydomain.com:8080/remote/';
    $config['soap_validate_cert'] = true;
    ?>
     

Share This Page