perfect server debian 8,6 error PureFTPd dev/sda1 / ext4 errors=remount-ro,discard 0 1

Discussion in 'Installation/Configuration' started by mart28, Apr 1, 2017.

  1. mart28

    mart28 Member

    Hello
    I'm following this tutorial
    https://www.howtoforge.com/tutorial/perfect-server-debian-jessie-nginx-bind-dovecot-ispconfig-3.1/2/
    In step
    13 Install PureFTPd and Quota

    nano /etc/fstab
    only have
    dev/sda1 / ext4 errors=remount-ro,discard 0 1

    dont have
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    # / was on /dev/sda1 during installation
    UUID=3dc3b58d-97e5-497b-8254-a913fdfc5408 / ext4 errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 1
    # swap was on /dev/sda5 during installation
    UUID=36bf486e-8f76-492d-89af-5a8eb3ce8a02 none swap sw 0 0
    /dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0

    # mount -o remount /
    [email protected]:~# mount: can't find UUID=3dc3b58d-97e5-497b-8254-a913fdfc5408




    what am I doing wrong
    Thank you
     
    Last edited: Apr 2, 2017
  2. mart28

    mart28 Member

    I am using a debian version of ovh server, I do not know if the installation process, automatically creates partitions, or is mounted
    Can this be the problem?
    How can I create and assemble them?
    Thank you



    ls -l /dev/disk/by-uuid
    total 0
    lrwxrwxrwx 1 root root 10 Apr 1 14:21 cbe73fc3-bff4-4bc5-8ba8-5ef4cc17db67 -> ../../sda1
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    There is nothing wrong with your fatsb, it just uses a different disk layout. Edit the line:

    /dev/sda1 / ext4 errors=remount-ro,discard 0 1

    and change it to:

    /dev/sda1 / ext4 errors=remount-ro,discard,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 1
     
  4. mart28

    mart28 Member

    Thanks till
    I have been reviewing the configuration of my server in vps in ovh
    And I think I can not use the hard drive as swap memory
    I can delete the current partition and create 2 partitions, but I can not install the operating system on the big partition, and ovh formats them by default
    This is normal?


    # df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 9.8G 1.1G 8.3G 12% /
    udev 10M 0 10M 0% /dev
    tmpfs 393M 5.3M 388M 2% /run
    tmpfs 982M 0 982M 0% /dev/shm
    tmpfs 5.0M 0 5.0M 0% /run/lock
    tmpfs 982M 0 982M 0% /sys/fs/cgroup


    top - 18:03:16 up 30 min, 3 users, load average: 0.00, 0.00, 0.00
    Tasks: 70 total, 1 running, 69 sleeping, 0 stopped, 0 zombie
    %Cpu(s): 0.0 us, 0.0 sy, 0.0 ni,100.0 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
    KiB Mem: 2009396 total, 128152 used, 1881244 free, 13316 buffers
    KiB Swap: 0 total, 0 used, 0 free. 58392 cached Mem





    # fdisk -u /dev/sda

    Command (m for help): n

    Select (default p): p
    Partition number (2-4, default 2): 2

    No free sectors available.

    With this tutorial I solve it?
    https://www.howtoforge.com/ubuntu-swap-file

    When the server is restarted, will it have swap memory?
    or
    Do I have to repeat the process?
    regards
    Thank you
     
  5. mart28

    mart28 Member

    Hello
    I have created the swapp memory as in this tutorial
    Https://www.howtoforge.com/ubuntu-swap-file
    And I have the fstab file

    Nano / etc / fstab


    / Dev / sda1 / ext4 errors = remount-ro, discard, usrjquota = quota.user, grpjquota = quota $
    / Swapfile none swap sw 0 0

    I do not have anything else

    it is right?
     

Share This Page