Perfect Server Centos 6.5 no smtpd.cert file

Discussion in 'Installation/Configuration' started by kephra, Aug 2, 2014.

  1. kephra

    kephra Member

    I have tried several times, installing Perfect Server for Centos 6.5 on my dotblock VPS. (Centos 6.4 has been running perfectly on same system)

    Dovecot fails to start because there is a missing smtpd.cert file in the /etc/postfix directory every time.

    I have tried yum remove postfix, then yum -y install postfix followed by an Ispconfig update and reconfiguring the services, but its still not there and dovecot fails with:

    Starting Dovecot Imap: doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 7: ssl_cert: Can't open file /etc/postfix/smtpd.cert: No such file or directory

    How can I recreate it?

    Added: I did a complete reinstall with the same result. This time, I executed "/etc/init.d/dovecot restart" just before installing IspConfig, and it restarted perfectly. Right after installing Ispconfig, dovecot would not longer restart and threw the error noted above.
    Last edited: Aug 2, 2014
  2. mrecho

    mrecho New Member

    Please try creating a certificate

    Hi, kephra

    I encountered the same issue, a few minutes ago, after completing the Perfect Server guide. I thought I caused the problem myself because I didn't follow the guide precisely and the install may have been affected by my prior experimenting. These guides are so top notch - I'm extremely grateful to the guys who make them.

    So I just created the certificate the configuration file was looking for and everything seems ok.

    in the directory /etc/postfix:

    openssl req -new -outform PEM -out smtpd.cert -newkey rsa:2048 -nodes -keyout smtpd.key -keyform PEM -days 365 -x509

    I used this page for reference:

    Hope it helps you
    Last edited: Aug 2, 2014
  3. kephra

    kephra Member

    Thanks mrecho, that fixes the problem. I have done Debian squeeze Perfect Servers, and Centos 6.4 without any hiccups, so there must be a glitch in the IspConfig install.
  4. cipito

    cipito New Member

    This helped me, too
  5. pooria

    pooria New Member

    it works for me too but i have another issue about this error in my log file :
    warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    and my postfix service dose not work fine
    can you help me ?
  6. mrecho

    mrecho New Member

    Hi, pooria
    I don't remember seeing this warning in my log file but as far as I can tell by reading about it online, you can safely ignore this warning. You can get rid of it if you want by following this post: EDIT: I can't post links but if you search for:
    dict_nis_init: NIS domain name not set - NIS lookups disabled
    you will find more info about this warning and how to remove it if you want.

    I don't think this warning is the reason why your postfix service doesn't work as it should. It's a red herring. If you're still having problems, it may be worth posting a new thread about postfix not working. There's no problem that can't be resolved - someone has probably experienced your particular issue before
    All the best

Share This Page