Perfect server Centos 4 (32bit) (my version is centos 4.8) mail problem

Discussion in 'HOWTO-Related Questions' started by j.smith19810808, Mar 11, 2010.

  1. j.smith19810808

    j.smith19810808 New Member

    I am having problems with my mail server guys can someone help?

    Thanks ever so much to everyone for helping me setup this service though as its working wonderfully only not for one slight problem.

    After some digging around on the web and sending an email out to an anonymous hotmail address I made say j.smith19810808@hotmail.co.uk (just one I made up to test my smtp server), as I wasnt getting anything in from the same username but googlemail.com.

    Its coming up with this message back from hotmails servers:


    This is what I suppose is probably the best thing albeit annoying for me, to protect their servers against spammers.

    Anyways is there anyway around this problem?

    I am obviously as it suggests using a dynamic ip address with virgin media at present, but what would you say is the best solution to get around this?

    Could I use mine as say a relay so I send an instruction out to gmail and then get them to send out an email or, something else?

    I would appreciate any response.

    Kind regards and I look forward to a reply,
    Jeremy.:confused:
     
  2. topdog

    topdog New Member HowtoForge Supporter

    Use your ISP's smtp server as your smarthost
     
  3. j.smith19810808

    j.smith19810808 New Member

    Can you help me achieve this?

    Sorry I know roughly what their about, mine would basically send off an instruction for them to send it, using my email exampleusername@domain.com yea?

    Then the user receives the email and might reply to it using my domain name yea? like user@mydomain.com (just as an example of course).

    Getting around this problem, have I got this correct?

    How would I set this up?

    I am happy though to get errors for now in the development of this server work around but just want to know some steps in converting this over.

    Kind regards and I look forward to a reply,
    Jeremy.
     
  4. j.smith19810808

    j.smith19810808 New Member

    I have tried doing this though on postfix with regards to the main.cf file:

    Changed the relayhost from being commented out to:

    relayhost = smtp.virginmedia.com

    But it brings up the following log message explaining its timed out:

    How do I get around this problem please?

    Its a bit weird though as I thought that would work, I may just go and look at my fathers smtp settings on his mail client and copy them over to my server, will this work?

    I look forward to a response,
    Jeremy.
     
  5. topdog

    topdog New Member HowtoForge Supporter

    It means there is a firewall blocking your server from connecting out on that port.
     
  6. j.smith19810808

    j.smith19810808 New Member

    Oh sorry it works now, was using virginmedia.com as the smtp server thats not correct for our IP address at the moment, its actually its old dns name before virgin took over, its actually:

    smtp.ntlworld.com and it works, just wanted to check with you my log though:

    It does look like its authenticating properly as per the howto tutorial?

    I left it the same as the settings as when I set it up just that I changed the relayhost part of the main.cf file havent changed anything else, as I darent do so lol.

    Any advice again is wonderful, thank you so much for your patience with me!
    Jeremy.
     

Share This Page