Perfect Install - Ubuntu 6.06 Dapper Questions

Discussion in 'HOWTO-Related Questions' started by Anim, Jun 5, 2006.

Thread Status:
Not open for further replies.
  1. falko

    falko Super Moderator ISPConfig Developer

    No, you must create proper DNS records for mydomainname.net and www.mydomainname.net, because your users' computers don't use the server's /etc/hosts file.
    The hostname in /etc/hosts isn't necessary, but if it's there the server doesn't have to do a DNS lookup for its own hostname.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please run

    Code:
    postconf -e 'mynetworks = [B][COLOR="Red"]127.0.0.0[/COLOR][/B]/8'
    and restart Postfix. What's the output of
    Code:
    netstat -tap
    then?
     
  3. wr19026

    wr19026 New Member

    Actually, I got pretty frustrated. So I did something really stupid: I Looked at another package. Which cost me 2 days to figure out that it sucks as it would not let me receive mails.

    So I did a new clean install of ISPConfig (with the my_networks suggestion btw) And everything just works! :)

    Well...Mail works, now I have to start figure out how to enable my second domain so that I don't get the "Shared IP" page when going there ;) But at least there's documentation that I can read.

    So all is well (for now) :)

    Till, Falko, you guys offer great and friendly support on top of some really high quality HowTos and software!
     
  4. tomas112

    tomas112 New Member

    server1.example.com' is not allowed to connect to this MySQL server'

    i'm having trouble with the command
    Code:
    mysqladmin -h server1.example.com -u root password yourrootsqlpassword
    which returns the error
    mysqladmin: connect to server at 'server1.example.com' failed
    error: 'Host 'server1.example.com' is not allowed to connect to this MySQL server'

    I've solved the hostname bit from the earlier posts.

    i've also commented out the bind-address filed in mysql conf file
     
    Last edited: Jun 17, 2006
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You must replace "server1.example.com" with your servers hostname.
     
  6. tomas112

    tomas112 New Member

    yes, of course. but since im following a copy and past tutorial I figured I could use the name falko suggested, therfore my host name is server1.example.com. It seams to me mysql doesn't give a #% about me commenting out that line. checked it and double checked.
     
  7. domino

    domino New Member

    I think the error giving root password to mysql needs to be looked into. The package might have changed in the repo. I ran into the same problem and it fixed itself after i left the install running overnight. I'm going to install another server on the local to see if I can reproduce the error.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Try this:
    Code:
    mysql -u root -p
    USE mysql;
    SELECT * FROM user;
    quit;
    What's the output of the SELECT statement?
     
  9. tomas112

    tomas112 New Member

    uhm, alot of stuff here's what i got:
    Code:
    mysql> SELECT * FROM user;
    +-----------+------------------+------------------+-------------+-------------+-------------+-------------+---------                                  ----+-----------+-------------+---------------+--------------+-----------+------------+-----------------+-----------                                  -+------------+--------------+------------+-----------------------+------------------+--------------+---------------                                  --+------------------+------------------+----------------+---------------------+--------------------+---------------                                  ---+----------+------------+-------------+--------------+---------------+-------------+-----------------+-----------                                  -----------+
    | Host      | User             | Password         | Select_priv | Insert_priv | Update_priv | Delete_priv | Create_p                                  riv | Drop_priv | Reload_priv | Shutdown_priv | Process_priv | File_priv | Grant_priv | References_priv | Index_priv                                   | Alter_priv | Show_db_priv | Super_priv | Create_tmp_table_priv | Lock_tables_priv | Execute_priv | Repl_slave_pri                                  v | Repl_client_priv | Create_view_priv | Show_view_priv | Create_routine_priv | Alter_routine_priv | Create_user_pr                                  iv | ssl_type | ssl_cipher | x509_issuer | x509_subject | max_questions | max_updates | max_connections | max_user_c                                  onnections |
    +-----------+------------------+------------------+-------------+-------------+-------------+-------------+---------                                  ----+-----------+-------------+---------------+--------------+-----------+------------+-----------------+-----------                                  -+------------+--------------+------------+-----------------------+------------------+--------------+---------------                                  --+------------------+------------------+----------------+---------------------+--------------------+---------------                                  ---+----------+------------+-------------+--------------+---------------+-------------+-----------------+-----------                                  -----------+
    | localhost | root             | 3eafef9700db93f2 | Y           | Y           | Y           | Y           | Y                                             | Y         | Y           | Y             | Y            | Y         | Y          | Y               | Y                                            | Y          | Y            | Y          | Y                     | Y                | Y            | Y                                                 | Y                | Y                | Y              | Y                   | Y                  | Y                                                  |          |            |             |              |             0 |           0 |               0 |                                                      0 |
    | server1   | root             |                  | Y           | Y           | Y           | Y           | Y                                             | Y         | Y           | Y             | Y            | Y         | Y          | Y               | Y                                            | Y          | Y            | Y          | Y                     | Y                | Y            | Y                                                 | Y                | Y                | Y              | Y                   | Y                  | Y                                                  |          |            |             |              |             0 |           0 |               0 |                                                      0 |
    | localhost | debian-sys-maint | 686865031fcbc9bc | Y           | Y           | Y           | Y           | Y                                             | Y         | Y           | Y             | Y            | Y         | Y          | Y               | Y                                            | Y          | Y            | Y          | Y                     | Y                | Y            | Y                                                 | Y                | N                | N              | N                   | N                  | N                                                  |          |            |             |              |             0 |           0 |               0 |                                                      0 |
    +-----------+------------------+------------------+-------------+-------------+-------------+-------------+---------                                  ----+-----------+-------------+---------------+--------------+-----------+------------+-----------------+-----------                                  -+------------+--------------+------------+-----------------------+------------------+--------------+---------------                                  --+------------------+------------------+----------------+---------------------+--------------------+---------------                                  ---+----------+------------+-------------+--------------+---------------+-------------+-----------------+-----------                                  -----------+
    3 rows in set (0.00 sec)
     
  10. domino

    domino New Member

    I ran a fresh install and the same error message during root password setup:

    Code:
    [email protected]:~$ sudo mysqladmin -u venus.xxxxxxxxxx.com -u root password xxxxxxxxxx
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'
    Now, I'm wordering if the error message has got something to do if whether you are on a home server or and dedicated box in a data center.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    First, Do not use Sudo, login as root user instead!

    The error above occurs, when the hostname you set with the -u parameter is not identical with the hostname you entered during setup. You can fix this later after you finished the complete installation by checking the mysql user database with phpmyadmin for empty passwords.
     
  12. domino

    domino New Member

    That was my multi attemp to try to circumvent the error. I just happed to post the last try. The first though fourth try, I was in root.

    So you're saying that instead the instruction:

    should be:

    If so, then will we get the error about setting the localhost mysql db?
     
    Last edited: Jun 18, 2006
  13. domino

    domino New Member

    That was my problem on the first install. I could not complete ISPConfig install if the error with the root mysql password was present during the Ubuntu installation.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    This means you must run
    Code:
    mysqladmin -h server1 -u root password yourrootsqlpassword
     
  15. falko

    falko Super Moderator ISPConfig Developer

    You made a typo. It must be

    Code:
    sudo mysqladmin [B][COLOR="Red"]-h[/COLOR][/B] venus.xxxxxxxxxx.com -u root password xxxxxxxxxx
    , not

    Code:
    sudo mysqladmin [B][COLOR="Red"]-u[/COLOR][/B] venus.xxxxxxxxxx.com -u root password xxxxxxxxxx
     
  16. tomas112

    tomas112 New Member

    that is exactly the command which results in the error message:
    Code:
    [email protected]:~# mysqladmin -h server1 -u root password ********
    mysqladmin: connect to server at 'server1' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'
    [email protected]:~#
    i've of course used my own password etc.
     
  17. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/hosts?
     
  18. tomas112

    tomas112 New Member

    thx for taking you the time, I appriciate it.
    her's my hosts and hostnames:
    Code:
    127.0.0.1       localhost.localdomain   localhost       server1
    192.168.0.100   server1.example.com     server1
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    [email protected]:~# hostname
    server1.example.com
    [email protected]:~# hostname -f
    server1.example.com
    iv'e tried without "server 1" in the first row (like you have it in the howto) without luck, only difference is the error msg:
    Code:
    [email protected]:~# mysqladmin -h server1.example.com -u root password xxxxx
    mysqladmin: connect to server at 'server1.example.com' failed
    error: 'Access denied for user 'root'@'server1.example.com' (using password: NO)'
     
  19. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
     
  20. tomas112

    tomas112 New Member

    Code:
    [email protected]:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN     3598/mysqld
    tcp        0      0 server1.example.:domain *:*                     LISTEN     3495/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN     3495/named
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     3495/named
    tcp6       0      0 *:ssh                   *:*                     LISTEN     3678/sshd
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     3495/named
    tcp6       0    148 server1.example.com:ssh ::ffff:192.168.0.1:1225 ESTABLISHED3785/0
     
Thread Status:
Not open for further replies.

Share This Page