Pear Error in multiple php version

Discussion in 'Installation/Configuration' started by biforme, Apr 27, 2016.

  1. biforme

    biforme New Member

    I have an issue with pear in php multiple versions, Ispconfig (on debian wheezy with php5.4 as primary version and php 5.3.29 as secondary) work fine.
    The log say:
    stderr: PHP message: PHP Warning:  require_once(): open_basedir restriction in effect. File(/opt/php-5.3.29/lib/php/Structures/DataGrid.php) is not within the allowed path(s):
    How to use pear packages with the php 5.3 with the restriction of open_basedir?
    I already put the path /opt/php-5.3.29/lib/php in System > Server config > Web > PHP Settings > PHP > open_basedir:
    Something wrong?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The path that you edited is fine. But thats just the default for new websites. you have to edit the open_basedir in the open_basedir field of the current existing website as well (options tab of the site).
    biforme likes this.
  3. biforme

    biforme New Member

    Hi Till, you are right!
    I also need to change permissions, from 644 to 755.
    Thanks a lot!

Share This Page