Passwords in MySQL 4.1 and up.

Discussion in 'Tips/Tricks/Mods' started by Hans, Oct 7, 2006.

  1. Hans

    Hans Moderator ISPConfig Developer

    If you did an update to MySQL 4.1.x and above,
    you probably will have problems with the MySQL passwords.
    Errors "like Client does not support authentication protocol" will occur.

    Reason for these kind of errors is that the password hashing mechanism was updated in MySQL 4.1 to provide better security and to reduce the risk of passwords being intercepted.

    To avoid these errors and if you want to stay compatibly with MySQL versions < 4.1 you can consider to add the next line under [MYSQLD] in your /etc/mysql/my.cnf file:

    old_passwords=1
     

Share This Page