"Password Lost" emails not sent

Discussion in 'Installation/Configuration' started by tfboy, Dec 29, 2013.

  1. tfboy

    tfboy Member

    Hi,
    I'm testing the password lost feature and emails are not getting sent out.
    All emails through hosted mailboxes work fine, and I wonder if the problem isn't dropped emails because the sender is potentially listed as [email protected]omain.

    I'm wondering because when I set up a new mailbox in ISPConfig3, the origin of the "Welcome" email is [email protected]omain when it should really be [email protected].

    Internal emails probably get through because they bypass all the normal HELO securities set up by external mail servers.

    So where can I define the true, valid email address for administrative purposes?

    Thanks :)
     
    Last edited by a moderator: Dec 31, 2013
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Take a look in the interface settings under System tab.
    There should be an option for using smtp account for mail sending and there's the option for admin name and email (that is used for sending).
     
  3. tfboy

    tfboy Member

    Thanks Marius.
    Still not working although it looks like I have another problem now I can't understand. So I'm trying to fix that first and then see if this works or not.
     
  4. tfboy

    tfboy Member

    OK, I had some issues sending email over port 587, that's fixed (it wasn't in the firewall rules).

    But the password lost emails don't get sent.

    I've created a local email box on the server and associated it to a test client to rule out potential invalid FQDNs, etc, but it still doesn't work.

    There doesn't seem to be any entry in the mail logs and nothing is stuck in the queue so I guess the sending isn't in fact attempted.

    On a sidenote, my initial thought whether valid or not still doesn't fix the originator of the new mailbox notification emails: it's still from "ISPConfig" who's email address is "[email protected]". This is less important, but not pretty - and it looks like those settings aren't taken from the Interface -> Main config -> Mail settings :confused:

    edit: screenshot attached
    [​IMG]
     
    Last edited: Dec 29, 2013
  5. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    The welcome email is something different.
    It is defined inside /usr/local/ispconfig/server/conf/mail/welcome_email_en.txt (or _de, etc.)

    Code:
    From: ISPConfig <[email protected]>
    Subject: Welcome to your new email account.
    
    Welcome to your new email account. Your webmaster.
    You can copy these files into conf-custom/mail/ and modify it to your needs.
     
  6. tfboy

    tfboy Member

    Thanks, that's done :)

    However, I think I've found the problem. Looking into the mail logs, I have the following:
    Code:
    Dec 31 10:15:02 myserver dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Dec 31 10:15:02 myserver postfix/smtpd[19768]: [COLOR="Red"]error: open database /etc/postfix/sender_access.db: No such file or directory[/COLOR]
    Dec 31 10:15:02 myserver postfix/smtpd[19768]: connect from localhost.localdomain[127.0.0.1]
    Dec 31 10:15:02 myserver postfix/smtpd[19768]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Dec 31 10:15:02 myserver postfix/smtpd[19768]: disconnect from localhost.localdomain[127.0.0.1]
    Dec 31 10:15:02 myserver dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Now postfix works fine, but looking at its configuration, it's set up to authenticate with MySQL (as per the ISPConfig setup). Here, it's looking for that file which doesn't exist. I'll do some more digging to see where this is set up, but if you know, please shout :)

    edit: Croydon, if you're a mod, feel free to remove the "- [email protected]omain problem?" part from the thread title as that's not the cause :)
     
    Last edited: Dec 31, 2013
  7. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

Share This Page