Password Lost don't send nothing to user

Discussion in 'ISPConfig 3 Priority Support' started by Marcio Urakawa, Jun 5, 2020.

  1. I'm having trouble getting the this function to work.
    Is anyone having the same problem?

    Debian Buster - ISPConfig 3.1.15p3
    e-mail log:
    Code:
    Jun  4 19:05:56 painel postfix/error[8242]: C5B9BE0E44: to=<[email protected]>, relay=none, delay=78951, delays=78950/0.21/0/0.05, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to smtp.gmail.com[2800:3f0:4003:c02::6c]:587: Network is unreachable)
    Jun  4 19:05:56 painel postfix/error[8246]: 23B53E0E3A: to=<[email protected]>, relay=none, delay=78951, delays=78951/0.18/0/0.08, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to smtp.gmail.com[2800:3f0:4003:c02::6c]:587: Network is unreachable)
    
    
    It's a bug ?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The e-mail log shows delivery of an e-mail failed, and reason given is network is unreachable. That is hardly a bug, at least not in ISPConfig. Postfix seems to try sending with IPv6, does your host have IPv6 connectivity?
    Is the network working properly for other uses?
    Is the e-mail still in mailq? Use as root command
    Code:
    mailq
     
  3. mailq: There are several like this
    Code:
    DC76FE19EA     1073 Thu Jun  4 09:56:52  [email protected]
    (delivery temporarily suspended: SASL authentication failed; cannot authenticate                                                   to server smtp.gmail.com[172.217.192.109]: no mechanism available)
                                             [email protected]
    
    D172EE10B7     1069 Wed Jun  3 21:27:18  [email protected]
    (delivery temporarily suspended: SASL authentication failed; cannot authenticate                                                   to server smtp.gmail.com[172.217.192.109]: no mechanism available)
                                             [email protected]
    
    My network is normal to use ftp for example.
    I am not using ipv6.

    When i host smtp.gmail.com
    Code:
    smtp.gmail.com has address 172.217.192.109
    smtp.gmail.com has IPv6 address 2800:3f0:4003:c02::6d
    nmap -v localhost | grep 587
    Discovered open port 587/tcp on 127.0.0.1
    587/tcp open submission

    It is a VM that is in my job, there is a firewall but there is no blocking for output.

    Do I need to open port 587 for entry?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, your issue is with sending. Try to test the smtp connection to Gmail by using telnet command from your server, you find instructions on how to test smtp connects using telnet on the internet. For me it seems as if either your firewall or a firewall of your internet provider blocks outgoing smtp connections. as @Taleman stated, this is a general email sending issue and not a problem with the ISPConfig password reset function.
     
  5. Code:
    telnet smtp.gmail.com 587
    Trying 172.217.192.109...
    Connected to smtp.gmail.com.
    Escape character is '^]'.
    220 smtp.gmail.com ESMTP f9sm5227049qtk.68 - gsmtp
     
  6. I uptade the file main.cf
    inet_protocols = all to inet_protocols = ipv4
    And the problem with network no appears more.

    But now when mailq
    Code:
    mailq
    -Queue ID-  --Size-- ----Arrival Time---- -Sender/Recipient-------
    06CC1E0076      840 Fri Jun  5 11:45:16  [email protected]
    (SASL authentication failed; server smtp.gmail.com[172.217.192.108] said: 534-5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbv?534-5.7.14 PGlxe78aycrnIK-elAkFxeOPP2-tfHNZtIu5VBfjDFNfYaK4ajOXD7SWdx5WQBobwelyJ?534-5.7.14 0H_UW6qOT8k9FKdARltYIQ2pWAAHjEhYS0HWjVm0IuKSEcqUIZyvqL9LtCmogNky>?534-5.7.14 Please log in via your web browser and then try again.?534-5.7.14  Learn more at?534 5.7.14  https://support.google.com/mail/answer/78754 j22sm7252319qke.117 - gsmtp)
                                             [email protected]
     
  7. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    Did you set up gmail as a relay for your sending?
     
  8. relayhost = [smtp.gmail.com]:587
    in main.cf
     
  9. Now appear:
    (TLS is required, but was not offered by host 127.0.0.1[127.0.0.1])
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    and you set this up trough ispconfig plus you set proper username and password for the authentication at Gmail?
     
  11. I'm testing it now by postfix:

    echo "test" | mail -s "teste" [email protected]

    Code:
    (SASL authentication failed; server smtp.gmail.com[172.217.192.109] said: 534-5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbv?534-5.7.14 kBWRfZA5HugoJsP6V8t2PenGYnsq95V0N_VdC4JTvwRkoAZbJaxHiofKzYRvPzryOn4lv?534-5.7.14 sbRMSb4Z_hfOwyYPEJJbluKb4WqghuOIF37rL4YWylFfR3He34E5t2oMcqWRECrl>?534-5.7.14 Please log in via your web browser and then try again.?534-5.7.14  Learn more at?534 5.7.14  https://support.google.com/mail/answer/78754 b11sm502355qti.50 - gsmtp)
    
    Now it's like google is blocking it.

    When I manage to send through the terminal I try to use ispconfig and post the result here of the conclusion.
     
  12. Hello! I managed to solve my problem.
    Everything was postfix settings and since i'm using gmail as a relay, i had to configure the IMAP account and enable access from other applications. Thanks to all for your help.
     
  13. How do I mark as solved?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    No need to mark it as resolved.
     

Share This Page