Password is not accepted from phpmyadmin.

Discussion in 'Installation/Configuration' started by kanour, Aug 31, 2006.

  1. kanour

    kanour New Member

    Hi all I have debian system where I updated mysql from 4.0 to 4.1. The problem is password hash which has changed as well.
    Is there any solution how to use long hash and phpmysqladmin or do I have to use short hash.

    I tried to use "old-passwords" option under "[mysql]" in /etc/mysql/my.cnf. When I restart mysql service and type "mysql -u root -p" I recieved:
    mysql: unknown option '--old-passwords'

    Can someone help
  2. kanour

    kanour New Member

  3. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/mysql/my.cnf?
  4. edge

    edge Active Member Moderator

    It would be a nice option to have this as an extra!

    This week I needed to convert 7 MySQL DB's to work with the OLD_PASSWORD option :/

    mysql -u root -p
    Enter password: ....
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 2380 to server version: 4.1.11-Debian_4sarge5-log
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    'web38_u1'@'localhost' = OLD_PASSWORD('this_sucks');
    Query OK, 0 rows affected (0.00 sec)
    mysql> quit
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you tried to set the old password option in my.cnf? I've used this on several installations successfully. There is no need to change the password encryption in ISPConfig when it is available as mysql config option.

    If you want to change it in ISPConfig, edit the file:

    /home/admispconfig/ispconfig/lib/classes/ispconfig_isp_datenbank.lib.php line 174 and 279.
  6. edge

    edge Active Member Moderator

    thank you till,

    I have now added this, and I think it should do the trick.

  7. Hans

    Hans Moderator ISPConfig Developer

    Last edited: Oct 4, 2006
  8. edge

    edge Active Member Moderator


    I was getting error's with my option (after restarting the MySQL some days later), so I removed it again..

    I'll give your option a try later this week.
  9. Hans

    Hans Moderator ISPConfig Developer

    Hi Edge,

    I've testes both options as i have upgraded mysql form 4.0.24 to 4.1.11.
    It works ok on my Debian server.

    If you have questions, we share our experiences. (As always) ;)

Share This Page