Parse error after install

Discussion in 'Installation/Configuration' started by pebcac, Sep 22, 2005.

  1. pebcac

    pebcac New Member

    Hi all. I did a search of the forum and did not see anything which matched so if this has been answered before, I apologize. I completed the ISPConfig install without error on my Debian Sarge box. When I go to the admin site and try to login with admin/admin, I get these error:

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'root@localhost' (Using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 76

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'root@localhost' (Using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 76

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:76) in /home/admispconfig/ispconfig/web/login/login.php on line 56

    So, I head over to the ispconfig_db_mysql.lib.php file and noticed that the information for host/user/password are all blank. I populate those fields and now I get this error:

    Parse error: parse error, unexpected '\"' in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 36

    Line 36 is the password line which does not have any '\' entries. I'm not sure where to go from here. Any pointers or some text reference would be greatly appreciated. Thanks in advance!
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Undo your changes in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php.

    /home/admispconfig/ispconfig/lib/config.inc.php is the file where you put your MySQL details.
     
  3. pebcac

    pebcac New Member

    I removed the changes I made previously, and took a look at the /home/admispconfig/ispconfig/lib/config.inc.php file. All of my correct information is already populated. To be on the safe side, I re-entered the same information into the file, restarted the ispconfig service, and now I'm back to the original error message. I know that the obvious reason for this is user error, however I'm not sure of where I'm making the mistake. As I mentioned previously, the install goes without a hitch. Is there anything else that you can recommend or should I just wipe out ispconfig and re-install?

    Thanks for your help.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Have you commented out "skip-networking" in the mysql my.cnf file and restarted your mySQL server?
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Does your MySQL password contain special characters that might cause the parse error?
     
  6. pebcac

    pebcac New Member

    Yes, to both of you...

    Skip-networking was commented and still is. Also, I did have special characters within my admin mysql password. I changed the password in mysql and in the config for Ispconfig and now I think the root issue is showing itself. It appears that I'm having a saslauthd config issue. Eventhough when I query my mail server, I'm getting 250-STARTTLS. When I launch the saslauthd service, I get the following error:

    /etc/init.d/saslauthd: line 54: syntax error near unexpected token `('

    And when checking that line, it reads:

    echo "(failed)."

    I've tried moving the quotes inside the brackets and removing the quotes but none of these work. I've now restored it to it's regular setting. I'm starting to do some google searches for that error now. If you guys have any ideas, I'm all ears. (obviously not enought brains yet :eek: ) hehe
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

Share This Page