ownCloud Sync Very Slow (Ubuntu 14.04.4, ispConfig, redis 3.0.7)

Discussion in 'Installation/Configuration' started by razor7, Mar 27, 2016.

  1. razor7

    razor7 Member

    Hi! I have installed php 7.0.4 on my home server because all the praises about being fast. I installed it on my Ubuntu Server 14.04.4 LTS with ispConfig The installation went just fine, and I also managed to enable PHP-FPM 7.0.4. Despite of this, ownCloud sync client tells me that the sync of my test files will take above 3 hours! Copying the test files through CIFS to my server takes about 3 to 5 minutes, maybe less.

    In this server I have installed ownCloud 9.0.0 using the official repo and set up apache to access it as global alias (like phpMyAdmin), so PHP is actually working as Apache Module, but I have to mention that if I setup ownCloud alias to work as CGI/Fast CGI or PHP-FPM, the results are the same.

    I have to mention that my sync client seems to sync 3 files then do a little sleep and then another 3 files, and so on...¿¿??

    As this is really slow, I decided to test the same setup on a fresh virtual machine using VirtualBox on my desktop PC, in that machine I have installed the same software but without following the perfect server guide, a base Ubuntu Server with Open SSH Server only and then installed the needed packages , so it's a base Apache, mysql 5.6, php 7.0.4, and redis. When I try to sync to the VM server, now the client syncs the files in about 5 minutes, as expected.

    This is not the first time I try to tackle this issue so I have prepared a very detailed report so maybe someone can help me solve this annoyance.

    That being said, lets start to report this bug (or enhancement, as you like)...

    Server configuration
    Operating system: Ubuntu Server 14.04.4 LTS (Linux lucas 3.13.0-83-generic #127-Ubuntu SMP Fri Mar 11 00:25:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux)

    Web server:
    Server version: Apache/2.4.7 (Ubuntu) - Server built: Jan 14 2016 17:45:23

    Database: MySQL 5.5.47-0ubuntu0.14.04.1

    PHP version: 7.0.4 (Server API: Apache 2.0 Handler)

    ownCloud version: 9.0

    Server hardware
    CPU: Intel(R) Core(TM) i7 860 @ 2.80GHz

    Motherboard: Gigabyte P55M-UD2

    RAM: 12GB 1333 MHz

    Server System HDDs: SSD Samsung 840 120Gb

    Server Storage HDDs: 2x WD Green WD20EARX 2TB (software RAID1 with mdadm)

    Network: (LAN) 1000 Mbit/s down / 1000 Mbit/s up

    Stress Test Info
    Stress Test Files: https://www.en0ch.se/stress-test/
    ownCloud Client: 2.1.1
  2. ztk.me

    ztk.me Active Member

    Can you verifi the results are still the same with a 2nd attempt doing a new clean perfect setup the same way?
    The main difference may be the change of the filesystems options to enable quota ... which shouldn't be that kind of a bottleneck.
    However owncloud features antivirus checking if clamav is installed - I don't know, but is that option turned on by chance?
    Have you compared the settings for php memory limits?
    razor7 likes this.
  3. razor7

    razor7 Member

    Ok, thanks for the reply, can you tell me what to do to check clamav enabled and quota? I think that I didn't the quota part in the tutorial, bu it think that clamav was installed.

    By the way, I have tested in three scenarios, one VM installed with https://github.com/enoch85/ownCloud-VM/blob/master/production/owncloud_install_production.sh, a second VM using a fresh Ubuntu Server 14.04.4 installing ISPConfig and a third scenario using a owncloud docker image, in all of them (VM's), the file syncing goes just fine, even syncing from wireless laptop on the same LAN, the only slow thing is my real 2 years old server installation, maybe in that time, I setup something that causes the pauses for security

    I really don't know what can be causing the slowness, I know that is my server, at least somehow

    Thanks in advise!
  4. ztk.me

    ztk.me Active Member

  5. razor7

    razor7 Member

    Thanks for the reply!

    I didn't that AV setup you mentioned in the link.

    My current guess is to waith till ubuntu 16.04 gets released and then try a complete new install. Will let you know then.

Share This Page