OWA (Exchange) to Subdomain of ISPCONFIG3

Discussion in 'Installation/Configuration' started by GCCM, Apr 19, 2021.

  1. GCCM

    GCCM New Member

    Hi Togehter

    Since i can different now Mailboxes to Roundcube / Exchange on same domain, i'll get users also Access to the "Webmail" / "Owa".

    Roundcube is still reachable and working on domain.tld/webmail
    For Exchange Server (OWA) i would use outlook.domain.tld or something else.

    So first i did on the Test-Domain a DNS entry for the outlook.domain.tld
    And now i'm on my Problem. I only have one fixed external IP-Address. If i add for Subdomain ob Websites the internal Domain it's not reachable from external. So i think there should be a "portmapping" or something like on the reverse proxy on ISPCONFIG self.

    If it's possible i would do simmelar like the webmail for all customer.

    i also don't care if it's solved by subdomain or /owa or whatever. It just should work and if possible be the same for all customer.
    There is also the Question about the HTTPS. Do deliver the ISPCONFIG3 the cert? Or do anyone know how to copy the cert automaticly to Exchange Server?

    Thank you guys! :)
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Correct, you would need to setup a reverse proxy to forward a vhost or path from ispconfig to your other server. There have been example configurations posted at times in the forums here (for reverse proxy config, I don't know if any were owa offhand).
     
  3. GCCM

    GCCM New Member

    I tried now different things also from Forum.

    There are always 3 Results:
    1. The Subdomain owa.domain.tld is automaticly forwarded to domain.tld
    2. I always got a HSTS failture
    3. The Website is not reachable

    Do we have here any Proxy Experts which could help me? :)

    Thank you.
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    How did you add owa.domain.tld, as a subdomain, not a website? you might try a vhost subdomain. Start with getting that to open the default placeholder page without redirecting, and then move on to proxy setup.
     

Share This Page