outlook wont send

Discussion in 'Installation/Configuration' started by terryoleary1981, Nov 8, 2008.

  1. terryoleary1981

    terryoleary1981 New Member

    Hi

    I had a problem sending any emails even from webmail, kept getting a relay error. I managed to fix the sending from the webmail but i'm still getting the 550 relay error message if i try to send an email from outlook.

    I've enabled the secure connection in outlook for it isnt that.... I tried adding my internal IP address to the mynetworks directive in the main.cfg but this doesnt seem to have had any affect.

    Code:
      554 5.7.1 <terry.oleary@gmail.com>: Relay access denied
    My Maillog says this:

    Code:
    Nov  8 20:39:50 mail dovecot: pop3-login: Login: user=<web23_admin>, method=PLAIN, rip=::ffff:192.1
    68.1.65, lip=::ffff:192.168.1.77
    Nov  8 20:39:50 mail dovecot: POP3(web23_admin): Disconnected: Logged out top=0/0, retr=0/0, del=0/
    0, size=0
    Nov  8 20:39:50 mail dovecot: pop3-login: Login: user=<web23_logger>, method=PLAIN, rip=::ffff:192.
    168.1.65, lip=::ffff:192.168.1.77
    Nov  8 20:39:50 mail dovecot: POP3(web23_logger): Disconnected: Logged out top=0/0, retr=0/0, del=0
    /0, size=0
    Nov  8 20:39:52 mail postfix/smtpd[24265]: disconnect from Bertha.lan[192.168.1.65]
    Nov  8 20:40:50 mail dovecot: pop3-login: Login: user=<web23_terry>, method=PLAIN, rip=::ffff:192.1
    68.1.65, lip=::ffff:192.168.1.77
    Nov  8 20:40:50 mail dovecot: POP3(web23_terry): Disconnected: Logged out top=0/0, retr=0/0, del=0/
    0, size=0
    Nov  8 20:40:50 mail dovecot: pop3-login: Login: user=<web23_admin>, method=PLAIN, rip=::ffff:192.1
    68.1.65, lip=::ffff:192.168.1.77
    Nov  8 20:40:50 mail dovecot: POP3(web23_admin): Disconnected: Logged out top=0/0, retr=0/0, del=0/
    0, size=0
    Nov  8 20:40:50 mail dovecot: pop3-login: Login: user=<web23_logger>, method=PLAIN, rip=::ffff:192.
    168.1.65, lip=::ffff:192.168.1.77
    Nov  8 20:40:50 mail dovecot: POP3(web23_logger): Disconnected: Logged out top=0/0, retr=0/0, del=0
    /0, size=0
    
    here is my main.cfg

    Code:
    
    queue_directory = /var/spool/postfix
    
    
    command_directory = /usr/sbin
    
    
    daemon_directory = /usr/libexec/postfix
    
    
    data_directory = /var/lib/postfix
    
    
    mail_owner = postfix
    
    myhostname = mail.spongecat.com
    
    mydomain = spongecat.com
    
    inet_interfaces = all
    
    
    
    unknown_local_recipient_reject_code = 550
    
    
    alias_maps = hash:/etc/aliases
    
    
    alias_database = hash:/etc/aliases
    
    
    debug_peer_level = 2
    
    debugger_command =
    	 PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    	 ddd $daemon_directory/$process_name $process_id & sleep 5
    
    
    
    	$process_id & sleep 1
    
    sendmail_path = /usr/sbin/sendmail.postfix
    
    newaliases_path = /usr/bin/newaliases.postfix
    
    
    mailq_path = /usr/bin/mailq.postfix
    
    setgid_group = postdrop
    
    
    html_directory = no
    
    
    manpage_directory = /usr/share/man
    
    
    sample_directory = /usr/share/doc/postfix-2.5.5/samples
    
    readme_directory = /usr/share/doc/postfix-2.5.5/README_FILES
    # Enable IPv4, and IPv6 if supported
    #inet_protocols = all
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    stmpd_sasl_authenticated_header = yes
    stmpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks,reject_unauth_destination
    mynetworks = 127.0.0.0/8
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    #smtpd_tls_cert_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    myhostname = mail.spongecat.com
    home_mailbox = Maildir/
    mailbox_command =
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    
    
    any ideas?
     
  2. _X_

    _X_ New Member

    does: web23_admin, web23_logger and web23_terry exist in

    /etc/postfix/virtusertable
     
  3. terryoleary1981

    terryoleary1981 New Member

    yeah they do existing in that file...
     
  4. _X_

    _X_ New Member

    Relay access denied - is smtp problem

    mail dovecot: POP3 - is ok and shows that user has loged in and loged out from pop3 server

    Also you need to enable option in Outlook accounts that is called: My outgoing server (SMTP) reauires authentication (enable: Use same settings as my incoming mail server)

    That option can be found: Tools/Account settings
    select account and then |Change|
    |More settings|
    Outgoing Server
     
  5. terryoleary1981

    terryoleary1981 New Member

    i have set the authentication up on the outlook client.
     
  6. _X_

    _X_ New Member

    also in my main.cf i dont have space characters in this line:
    stmpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks,reject_unauth_destination

    space between permit_sasl_authenticated, and permit_mynetworks,reject_unauth_destination
     
  7. _X_

    _X_ New Member

    btw what tutorial did you followed?
     
  8. terryoleary1981

    terryoleary1981 New Member

    I removed the space but that hasnt made any difference.... I followed the perfect fedora 9 server setup.
     
  9. _X_

    _X_ New Member

    can you paste error in mail.log. it should look like this:
    server1 postfix/smtpd[25684]: NOQUEUE: reject: RCPT from unknown[xxx.xxx.xxx.xxx]: 554 5.7.1 <terry.oleary@gmail.com>: Relay access denied; from=<user1@user1.com> to=<terry.oleary@gmail.com> proto=ESMTP helo=<HOME>

    or something similar
     
  10. _X_

    _X_ New Member

    what is the result of:
    telnet localhost 25
    ehlo server1.com <example

    and try:
    auth login
    username
    password

    does it give: 535 5.7.8 Error: authentication failed: authentication failure
     
  11. _X_

    _X_ New Member

    found few differences with tutorial main.cf:
    in tutorial main.cf there is no line:
    mydomain = spongecat.com

    in tutorial line:
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    ddd $daemon_directory/$process_name $process_id & sleep 5

    in yours:
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    ddd $daemon_directory/$process_name $process_id & sleep 5
    $process_id & sleep 1
     
  12. _X_

    _X_ New Member

    AND THE REAL PROBLEM IS:

    stmpd_sasl_authenticated_header = yes
    ^^
    stmpd_recipient_restrictions =
    ^^
    permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination

    smtpd_sasl not stmpd_sasl in both lines :)

    simple typo :)
     
  13. terryoleary1981

    terryoleary1981 New Member

    hey thanks! cant believe i looked at that code so many times and didnt spot it lol... thanks all is working now
     

Share This Page