Outlook 2007 smtp

Discussion in 'Installation/Configuration' started by statiic, Mar 8, 2007.

  1. statiic

    statiic New Member

    I really get sick of the smtp crap.

    Somehow my outlook 2007 cant send email through smtp, but if I login into the webmail manually it can send emails.

    I restarted smtp, saslauthd
    I checked postfix conf all correct
    I changed in outlook the settings that smtp requires auth.

    I have no clue what else can be the problem. If anyone has any ideas then send them in ;)
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Are you using TLS authentication? IIRC, I've seen problem reports on the Postfix mailing lists about broken TLS directories in Outlook 2007. Better check the M$ site....
  3. statiic

    statiic New Member

    # Please be sure to read the /usr/share/doc/postfix-*/README.MDK file
    # to learn about differences from stock postfix to Mandriva package.
    # This file contains only the parameters changed from a default install
    # see /etc/postfix/main.cf.dist for a commented, fuller version of this file.

    # These are changed by postfix install script
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    html_directory = /usr/share/doc/postfix-2.3.3/html
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    command_directory = /usr/sbin
    manpage_directory = /usr/share/man
    daemon_directory = /usr/lib64/postfix
    newaliases_path = /usr/bin/newaliases
    mailq_path = /usr/bin/mailq
    queue_directory = /var/spool/postfix
    mail_owner = postfix

    # User configurable parameters
    message_size_limit = 3072000
    inet_interfaces = all
    mynetworks_style = host
    #delay_warning_time = 4h
    smtpd_banner = $myhostname ESMTP $mail_name ($mail_version) (Mandriva Linux)
    unknown_local_recipient_reject_code = 450
    smtp-filter_destination_concurrency_limit = 2
    lmtp-filter_destination_concurrency_limit = 2
    recipient_delimiter = +
    owner_request_special = no
    alias_maps = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    mydomain = heldermarketing.nl
    myhostname = server1.$mydomain
    mydestination = /etc/postfix/local-host-names, localhost.heldermarketing.nl
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable
  4. edge

    edge Active Member Moderator

    Did you enable "My outgoing server (SMTP) requires authentication" in Outlook?

    Outlook 2007 > Tools > Account Settings > your-email-accout > More Settings... > Outgoing Server > Enable "My outgoing server (SMTP) requires authentication"
  5. edge

    edge Active Member Moderator

    rereading you message I see you did allready.
  6. statiic

    statiic New Member

    Haha yep ;)
  7. statiic

    statiic New Member

    Anyone more ideas for this problem? Above didnt solved them ;)
  8. falko

    falko Super Moderator ISPConfig Developer

    Please double-chack that you enabled "Server requires authentication."
    If that doesn't help: any errors in your mail log? What's the output of
    ps aux|grep saslauthd
  9. statiic

    statiic New Member

    The issue has been resolved. For all Dutch folks in here. Make sure your ISP doesnt block port 25 back home ;)

    Thats the reason why you cant connect to the smtp port 25 hehe
  10. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    I don't care whether my ISP blocks port 25. I don't run production servers on an ADSL line ;)
  11. edge

    edge Active Member Moderator

    I'm Dutch, and my ISP does not block port 25.
    Last edited: Mar 9, 2007
  12. statiic

    statiic New Member

    If you read carefully you would see that I dont run my server on an adsl line. My server is in an data center, but my connection back home is on an adsl line.
    So when my provider blocks the outgoing port 25 traffic. I cant connect to the smtp port on my server.

  13. Hans

    Hans Moderator ISPConfig Developer

    Some Internet Service Providers in Holland do not block port 25, like XS4ALL and Quicknet. :)
  14. statiic

    statiic New Member

    Haha yeah I know, but I'm the unlucky guy with an provider which does. I wait for the new 100mbit lines which are upcoming and then I swap from provider hehe ;)

Share This Page