Outlook 2003 issue with courier-pop3

Discussion in 'Installation/Configuration' started by RotHorseKid, Nov 30, 2005.

  1. RotHorseKid

    RotHorseKid New Member

    Hi folks.

    One of my users is fetching a whole shitload (15 or 20) of POP3 eMail accounts using Outlook 2003 from my ISPconfig server (SuSE9.3, perfect setup).

    This does not work as expected. The POP sessions behave erratically.
    Most of them work, but some accounts seem to time out after a while, with a DISCONNECT. These accounts seem to be those with many mails in the Inbox.
    Effectively these accounts cannot be downloaded, because on a retry, the download starts anew (the already downloaded messages were not erased), and then times out again.

    I heard of an issue with early versions of Outlook 2003 and POP timeouts, but the Office 2003 version used has service pack 2 installed.

    Anyone here that kknows about this issue? Is it a problem with my pop server config? Any help would be appreciated, as the user I speak about is my boss ;)

    Regards,
    RHK
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you install Courier, as described in the tutorial?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use maildir or mailbox storage format? This sounds like thy typical mbox problems, if the mbox file is getting too large you may get timeouts while the server is copying the file for delivery.
     
  4. RotHorseKid

    RotHorseKid New Member

    Falko, Till.

    as the HowTo is very intensely coercing the user to use Courier with MailDir, I used MailDir format of course. I followed the Perfect Setup HowTo to the letter (at least I did after not being able to do a clean ISPconfig install on the first try ;))

    Regards.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    OK, Maildir is the right storage format for large accounts. Please hae a look in your mail log and syslog if there are any errors for this email account. If you search for a specific user in the logs, you can use this comand:

    tail -n 1000 /path/to/the/logfile | grep "webX_username"

    This searches for the string "webX_username" in the last 1000 lines of the logfile /path/to/the/logfile.
     
  6. enodr

    enodr New Member

    Hi,

    I have exactly the same problem on my server. It's a Debian Sarge stable with VHCS (web interface) and Courier Pop3. I have 3 outlook users who are experiencing the problem:
    they are disconnected before all the messages are downloaded (so they are not deleted from the server). As a consequence they are always downloading the same messages over and over.

    For one of the user the downloading stopped at msg n°250 or so, but for the two others it can stop at message 5 or 10. I do not know if the connection stops always at the same message as I was unable to reproduce it myself.

    The 3 persons are running Outlook (one is Outlook 2003, I don't know for the two other persons).

    Here is what says the log file:
    Dec 6 19:09:10 clara courierpop3login: DISCONNECTED, user=[email protected], ip=[::ffff:193.251.40.76], top=0, retr=588, time=1
    Dec 6 19:19:13 clara courierpop3login: DISCONNECTED, user=[email protected], ip=[::ffff:193.251.40.76], top=0, retr=588, time=1
    ...
    Dec 6 20:19:01 clara courierpop3login: DISCONNECTED, user=[email protected], ip=[::ffff:193.251.40.76], top=0, retr=1930730, time=75


    Best regards.
     
    Last edited: Dec 7, 2005
  7. falko

    falko Super Moderator ISPConfig Developer

    What happens if your users use another email client (e.g. Thunderbird or Outlook Express)? Still the same behaviour?
     

Share This Page