outgoing registration email is not going I running webserver server behind a proxy

Discussion in 'Server Operation' started by vtapas, Apr 16, 2010.

  1. vtapas

    vtapas New Member

    Hi,
    I have a small problem to which I do not have a clue.
    I am having a linux router which has a public IP and have hosted a few websites from computers which are on lan.
    The scenario is like this

    Code:
     router--->  www.myserver.com         internal LAN ip 192.168.0.1 
    
      domu1----->www.myserver.com/domu1    on internal LAN 192.168.0.11
    
      domu2----->www.myserver.com/domu2    on internal LAN 192.168.0.12
    
      domu3----->www.myserver.com/domu3    on internal LAN 192.168.0.13
     
      domu4----->www.myserver.com/domu4    on internal LAN 192.168.0.14
    

    Now the sites www.myserver.com/domu1 to domu4 all have registration pages.
    I have drupal as web development platform.These sites can be accessed on internet with only home pages.
    When a user tries to create a new account on any of them
    say for example www.myserver.com/domu1

    the outgoing registration email is not going.
    What steps should I do to check it ?
    How can it be made possible?
    To my mind it comes I should setup SMTP and do some forwarding routing with ports etc but I am not sure so need suggestions.
    I googled about SMTP configuration and came across that Drupal does not seems to have good SMTP configuration http://ubuntuforums.org/archive/index.php/t-855064.html
     
    Last edited: Apr 16, 2010
  2. falko

    falko Super Moderator

  3. vtapas

    vtapas New Member

    No I have a static IP.
    In the webpage you mentioned I see all as green what does that mean.
     

Share This Page