Outgoing Mail Problems

Discussion in 'Installation/Configuration' started by mjhasbach, May 27, 2010.

  1. mjhasbach

    mjhasbach New Member

    I followed the tutorial The Perfect Server - Ubuntu 10.04 [ISPConfig 3] verbatim and I'm pleased to say the process has been far less painful than I imagined (first time Linux server). I have been developing my website locally for a few days now and now that my domain name is done propagating and pointing to my server, I want to make sure I get everything ironed out.

    I can receive emails fine, but I am unable to send any emails via squirrelmail. During the tutorial, I told configured squirrelmail to use courier. My ISP is not blocking ports 25, 110, 143 and these ports are properly opened in my router.

    I have an email domain set up with the following settings:
    Server: server1.domain.tld
    Domain: domain.tld
    Spamfilter: Not enabled

    I have a mailbox set up with the following settings:
    [email protected]
    Spamfilter: Not enabled
    Enable Receiving [yes]

    Also, far as control panels go, I'm used to CPanel where it spells out the correct IMAP / POP3 login information for you. It is my goal to be able to access my email via IMAP, but I don't know what the correct settings would be for my particular [default] case (e.g. Incoming IMAP Server, Outgoing SMTP Server, etc). I'm also interested in figuring out how to enable TLS.

    One last issue worth mentioning is the fact that I cannot access squirrelmail via domain.tld/webmail, so for testing purposes I have just been using 192.168.x.x/webmail. Using the former brings me to a ISPConfig 404 page.

    Thanks in advance! Excellent site and guides.
  2. mjhasbach

    mjhasbach New Member

    Update: I have tried sending to Gmail accounts and just tried a Hotmail account. Gmail didn't give me any feedback so I figured my server just wasn't sending...


    I got a "Undelivered Mail Returned to Sender" email from Hotmail:

    Cool, so my outgoing mail is sending, but it's being blocked. How do I fix this?

    Also, I just figured out that I can connect to my email via IMAP by just using my server's internal IP address (192.168.x.x) or by simply entering domain.tld as my Incoming IMAP Server. Also, I can send emails (to myself anyway) by using domain.tld as my Outgoing SMTP Server.
  3. mjhasbach

    mjhasbach New Member

    Nevermind, I got it working. Possible solutions:

    1. Configure outgoing mail to send over port 587
    2. Remove your IP from the Spamhaus PBL

    I did both. Outgoing emails get delivered perfectly now.

Share This Page