Outgoing mail asking for password

Discussion in 'Installation/Configuration' started by defsoul, Apr 9, 2013.

  1. defsoul

    defsoul New Member

    Hello,

    I setup "The Perfect Server - Ubuntu 10.04 [ISPConfig 3]" a while ago and it has been working perfect for a while but today from no where when a user tries to send mail it asks for the user name and password, receiving (pop3) is still working fine, what could have happened over night and how can i fix it?

    thanks
     
  2. edge

    edge Active Member Moderator

    In your email client you will need to enable "My outgoing server (SMTP) requires authentication" and set it to "Use same settings as my incoming mail server"
     
  3. defsoul

    defsoul New Member

    Hi,

    It is enabled and its all the addresses (I've got 8 addresses), and everything was working fine yesterday and i didnt change anything
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
     
  5. defsoul

    defsoul New Member

    This is what I get


    root@mail:~# tail -f /var/log/messages
    Apr 11 07:45:00 mail kernel: [ 19.131204] drm: registered panic notifier
    Apr 11 07:45:00 mail kernel: [ 19.131253] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
    Apr 11 07:45:00 mail kernel: [ 19.131360] snd_intel8x0 0000:00:1f.5: PCI INT B -> GSI 17 (level, low) -> IRQ 17
    Apr 11 07:45:00 mail kernel: [ 19.175763] Adding 1690620k swap on /dev/sda5. Priority:-1 extents:1 across:1690620k
    Apr 11 07:45:00 mail kernel: [ 19.408587] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0
    Apr 11 07:45:00 mail kernel: [ 19.468098] intel8x0_measure_ac97_clock: measured 52726 usecs (2541 samples)
    Apr 11 07:45:00 mail kernel: [ 19.468105] intel8x0: clocking to 48000
    Apr 11 07:45:39 mail kernel: [ 59.373857] ip_tables: (C) 2000-2006 Netfilter Core Team
    Apr 11 07:46:36 mail pure-ftpd: (?@70.62.242.17) [INFO] New connection from 70.62.242.17
    Apr 11 07:46:36 mail pure-ftpd: (?@70.62.242.17) [INFO] Logout.
    Apr 11 07:50:01 mail pure-ftpd: (?@::1) [INFO] New connection from ::1
    Apr 11 07:50:01 mail pure-ftpd: (?@::1) [INFO] Logout.
    Apr 11 07:50:02 mail kernel: [ 322.181039] ip6_tables: (C) 2000-2006 Netfilter Core Team

    root@mail:~# less /var/log/messages
    Apr 7 06:38:08 mail rsyslogd: [origin software="rsyslogd" swVersion="4.2.0" x-pid="521" x-info="http://www.rsyslog.com"] rsyslogd was HUPed, type 'lightweight'.
    Apr 7 06:40:02 mail pure-ftpd: (?@::1) [INFO] New connection from ::1
    Apr 7 06:40:02 mail pure-ftpd: (?@::1) [INFO] Logout.
    Apr 7 06:41:36 mail pure-ftpd: (?@70.62.242.17) [INFO] New connection from 70.62.242.17
    Apr 7 06:41:36 mail pure-ftpd: (?@70.62.242.17) [INFO] Logout.
    Apr 7 06:45:02 mail pure-ftpd: (?@::1) [INFO] New connection from ::1
    Apr 7 06:45:02 mail pure-ftpd: (?@::1) [INFO] Logout.
    Apr 7 06:46:37 mail pure-ftpd: (?@70.62.242.17) [INFO] New connection from 70.62.242.17
    Apr 7 06:46:37 mail pure-ftpd: (?@70.62.242.17) [INFO] Logout.
    Apr 7 06:50:02 mail pure-ftpd: (?@::1) [INFO] New connection from ::1
    Apr 7 06:50:02 mail pure-ftpd: (?@::1) [INFO] Logout.
    Apr 7 06:51:38 mail pure-ftpd: (?@70.62.242.17) [INFO] New connection from 70.62.242.17
    Apr 7 06:51:38 mail pure-ftpd: (?@70.62.242.17) [INFO] Logout.
    Apr 7 06:55:01 mail pure-ftpd: (?@::1) [INFO] New connection from ::1
    Apr 7 06:55:01 mail pure-ftpd: (?@::1) [INFO] Logout.
    Apr 7 06:56:36 mail pure-ftpd: (?@70.62.242.17) [INFO] New connection from 70.62.242.17
    Apr 7 06:56:36 mail pure-ftpd: (?@70.62.242.17) [INFO] Logout.
    /var/log/messages
     
  6. markc

    markc New Member

    Try this while you are actually attempting to connect...
    Code:
    tail -f /var/log/mail.log
     
  7. defsoul

    defsoul New Member

    Apr 11 15:46:28 mail postfix/smtpd[25506]: warning: 105.226.254.61: hostname 226-254-61.dsl.subscriber.myisp.net verification failed: Name or service not known
    Apr 11 15:46:28 mail postfix/smtpd[25506]: connect from unknown[105.226.254.61]
    Apr 11 15:46:28 mail postfix/smtpd[25506]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Apr 11 15:46:28 mail postfix/smtpd[25506]: warning: unknown[105.226.254.61]: SASL LOGIN authentication failed: generic failure
    Apr 11 15:46:28 mail postfix/smtpd[25506]: lost connection after AUTH from unknown[105.226.254.61]
    Apr 11 15:46:28 mail postfix/smtpd[25506]: disconnect from unknown[105.226.254.61]
     
  8. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You must (re)start saslauthd, if it´s not running. Check it with /etc/init.d/saslauthd status or ps -aux|grep saslauthd

    To start saslauth-daemon run /etc/init.d/saslauthd start
     
  9. markc

    markc New Member

    This is weird, one of my test servers (Ubuntu 13.04 / 3.0.5.2) stopped working with a similar error but I was changing it from dovecot/sieve to courier-imap/maildrop. I did an upgrade.php but I do not have the sasl files you mention, and indicated in other forums posts when searching for similar errors. My /etc/init.d/saslauthd is zero bytes and what is even more confusing is that my main working ispc system (still using dovecot) is the same, no real obvious sasl files I've seen in various posts and yet that server works just fine.

    As it turns out I solved my problem with this particular server by uninstalling postfix and setting up courier-mta instead... and it's working off the ispc auth tables in MySQL.
     
  10. defsoul

    defsoul New Member

    the other thing i've noticed is when i use the private ip for my incoming and outgoing server it works but when i use dns mail.myserver.com or public ip is asks for the password
     

Share This Page