Outgoing email DKIM signing missing

Discussion in 'Installation/Configuration' started by Duvy, Mar 14, 2022.

  1. Duvy

    Duvy New Member

    Hi there,
    on Debian 11, Ispconfig 3.2.7 new installation, but there's some issue with the DKIM signing of the outgoing emails. It's a fresh install, so wondering what am I missing.
    • In ISPConfig, mail domain added, created a DKIM priv/pub key, added to the DNS
    [email protected]:~# amavisd-new testkeys
    TESTING#1 ***.com: default2._domainkey.***.com => pass
    • mail.err is empty, Amavis starts, runs and binds on the required ports.
    [email protected]:~# netstat -tap | grep amavis
    tcp 0 0 localhost:10024 0.0.0.0:* LISTEN 521097/amavisd-new
    tcp 0 0 localhost:10026 0.0.0.0:* LISTEN 521097/amavisd-new
    tcp 0 0 localhost:58388 localhost:10025 ESTABLISHED 521107/amavisd-new
    [email protected]:~# tail -n 100 /var/log/mail.log |grep amavis
    Mar 14 02:08:20 s3 amavis[521097]: starting. /usr/sbin/amavisd-new at s3.***.com amavisd-new-2.11.1 (20181009), Unicode aware, LANG="en_US.UTF-8"
    Mar 14 02:08:20 s3 amavis[521097]: perl=5.032001, user=113, EUID: 113 (113); group=, EGID: 121 121 (121 121)
    Mar 14 02:08:20 s3 amavis[521097]: Net::Server: Group Not Defined. Defaulting to EGID '121 121'
    Mar 14 02:08:20 s3 amavis[521097]: Net::Server: User Not Defined. Defaulting to EUID '113'
    Mar 14 02:08:20 s3 amavis[521097]: No ext program for .lz4, tried: lz4c -d
    Mar 14 02:08:20 s3 amavis[521097]: No ext program for .rpm, tried: rpm2cpio.pl, rpm2cpio
    Mar 14 02:08:20 s3 amavis[521097]: No ext program for .rar, tried: unrar-free
    Mar 14 02:08:20 s3 amavis[521097]: No ext program for .zoo, tried: zoo
    Mar 14 02:08:20 s3 amavis[521097]: No ext program for .doc, tried: ripole
    Mar 14 02:08:20 s3 amavis[521097]: No decoder for .F
    Mar 14 02:08:20 s3 amavis[521097]: No decoder for .doc
    Mar 14 02:08:20 s3 amavis[521097]: No decoder for .lz4
    Mar 14 02:08:20 s3 amavis[521097]: No decoder for .zoo
    • Sending out an email generates this amavis entry into the mail.log:
    Mar 14 02:08:32 s3 amavis[521107]: (521107-01) Passed CLEAN {RelayedOpenRelay}, [127.0.0.1] <[email protected]***.com> -> <[email protected]*********.com>, Message-ID: <[email protected]***.com>, mail_id: i8HnELmhgxs1, Hits: -, size: 826, queued_as: 9D1CB1040DA0, 62 ms
    the recipient is not hosted locally.

    Any ideas what am I missing?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. Duvy

    Duvy New Member

    It's a single and new one, sorry old habits, added the amavis manually. With rspamd it works awesomely. Thanks for the info.
     

Share This Page