OScommerce & PHPmysqladmin not working!

Discussion in 'Server Operation' started by willebanks, Nov 18, 2006.

  1. willebanks

    willebanks New Member

    Howdy all,

    I am having a hard time getting PHPmysqladmin and OScommerce to work on my Fedora Core 5 ISPconfig server.

    I can get an info.php file to work on one of my Virtual Sites but once I change the directory structure per the OScommerce installation guide I get a register_globals error.

    Secondly, PHPmysqladmin requires installation into the Document Root of the server. After moving everything I can see all the files when I go to the local address -127.0.0.1 - yet the .php scripts don't work!

    I'm pretty sure that this has to do with PHP being disabled globally, yet I'm not sure what the fix is...if there is one!

    As usual any help will be appreciated ...

    Will Banks
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the exact error message? What's the current value of register_globals in your php.ini?

    You can install phpMyAdmin in any subdirectory.

    No, that's not the problem.
     
  3. willebanks

    willebanks New Member

    Hi Falko,

    The error went something like..."Fatal Error register_globals not active, please make appropriate changes to your php.ini file".

    This may not be exact but it is the jist of the error!

    I had checked to be sure that PHP was working by installing and testing a file called phpinfo.php in the "web" directory of the virtual host I wish to set up OScommerce...this worked no problem! Yet I can't seem to get PHP to work any where else on the system even after I "turned on" register_globals in the php.ini file and restarted Apache.

    I had placed all the files for PHPmysqladmin is a directory off the Document Root which I believe is /var/www/html! All that happens is the PHP file is "opened" in the browser not executed. I have check the folder permissions and all seems as it should...I'm at a loss

    As usual whenever I make a changes it screws up the whole system and I have to re-install...Thank God I had a backup this time!

    Hope this helps
    Will
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Have a look here: http://www.howtoforge.com/forums/showthread.php?t=5928&highlight=register_globals apache directives

    You must install phpMyAdmin in a web site created by ISPConfig, not in /var/www/html. Have a look here: http://www.howtoforge.com/forums/showthread.php?t=1461&highlight=disable php globally
     
  5. willebanks

    willebanks New Member

    Sorry I didn't get back to you sooner!

    I actually have osCommerce up and running! Amazing! I gave up on PHPmysqladmin as I want to learn how to use the mysql command line and all that good stuff...so as usual thanks for all the help!
    Just in case anyone else wants to setup osCommerce.

    I had to add "php_admin_value register_globals On" and "php_admin_value register_long_arrays On" in the Apache Directives of the virtual site for the setup to run correctly.

    It took me 3 tries, but once I added the above directive it was smooth sailing! I wish I could share the URL but it's for work and I still have to set up some security..not that I don't trust all my friends here. I'm sure you all understand

    Thanks again,

    Will
     

Share This Page