[OS Debian Sarge] APT Get Problem

Discussion in 'Installation/Configuration' started by pontifex, Mar 8, 2006.

  1. pontifex

    pontifex New Member

    Hi everyone,
    i have a question - problem with apt-get.
    when i type in
    Code:
    apt-get upgrade
    the following screen comes up:
    Code:
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Die folgenden Pakete sind zurückgehalten worden:
      bind9 bind9-host dnsutils fetchmail freetype1-tools htmldoc
      libapache2-mod-php4 libapache2-mod-php5 libbind9-0 libdb3 libdb3-dev
      libdb3-util libdbd-mysql-perl libfam0c102 libfltk1.1 libgnutls11
      libhtml-parser-perl libisccc0 libisccfg1 libkrb5-17-heimdal libpam-modules
      libperl5.8 libsasl2 libsasl2-dev libsasl2-modules libsasl2-modules-sql
      libselinux1 libsensors3 libttf2 libx11-6 locales passwd perl perl-base
      perl-modules php4 php4-cli php4-common php4-curl php4-dev php4-domxml
      php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc
      php4-snmp php4-xslt php5 php5-clamavlib php5-cli php5-common php5-curl
      php5-dev php5-gd php5-imap php5-ldap php5-mhash php5-mysql php5-odbc
      php5-snmp php5-sqlite php5-xmlrpc php5-xsl python2.4 sasl2-bin snmp sysvinit
      texinfo unixodbc w3m xfree86-common
    How can i update that packages or what can i do against that..?

    Cheers
    PM
     
  2. till

    till Super Moderator

    Apt has kept these packages back becuse they may contain changes which make a reconfiguration nescessary.

    You can update the packages for example with:

    apt-get install bind9 bind9-host dnsutils fetchmail freetype1-tools htmldoc

    After installing them, check if all services are still running fine.
     
  3. pontifex

    pontifex New Member

    hi,
    i installed some packages by hand. afterwards i am getting the follwoing error message when i try to call apt-get upgrade

    Code:
    apt-get upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Sie möchten wahrscheinlich »apt-get -f install« aufrufen, um dies zu korrigieren.
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
      xfree86-common: Hängt ab: x11-common ist aber nicht installiert
    E: Nichterfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
    mail:~# apt-get upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Sie möchten wahrscheinlich »apt-get -f install« aufrufen, um dies zu korrigieren.
    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
      xfree86-common: Hängt ab: x11-common ist aber nicht installiert
    E: Nichterfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
    
    how can i solve that?

    apt-get - f install does not help...

    Cheers
    PM
     

Share This Page