Discussion in 'Suggest HOWTO' started by jsable, Aug 13, 2010.

  1. jsable

    jsable New Member

    I have been trying to get this program to install on ubuntu 10.04 (32) and have installed all of the required dependencies, but when I open the web browser and type in the address, it just downloads a php script and does not run the browser web install. This is a great program and I have used it and installed it on a windows box, but I am now only running linux and would like to continue using this program.
    The company does not offer a "howto" on installing it from linux, and I am looking for a little help. I have tried other websites but have not had any luck. Any help is appreciated.

  2. falko

    falko Super Moderator ISPConfig Developer

    Did you install PHP? Which tutorial (URL) did you use to set up the system?
  3. jsable

    jsable New Member

  4. dipeshmehta

    dipeshmehta New Member

  5. jsable

    jsable New Member


    Thank you for the link, I could not find that when I looked for it :confused: I think because I was looking for the web install. It appears that my problem is with apache, there is no user "apache" and there is no group for users under "apache". When I tried the chown command, I got:

    john@MediaPita:/var/www$ sudo chown apache /var/www/orangehrm
    chown: invalid user: `apache'

    I am sure that there is something else I missed.

  6. dulitha

    dulitha New Member


    If it fails try one of below.

    chown -R apache:apache /location
    chmod -R 755 /location


    chown -R www-data /location
    chmod -R 755 /location

    If above failed please try to uninstall apache php and mysql and try to install lamp stack.

    Use OrangeHRM latest stable version which is 2.6.

  7. jsable

    jsable New Member

    Thank you for the reply, I was able to find out that in Ubuntu, there is no user or group for "apache", the group is "www-data". Once I changed ownership to this group, the program worked as advertised.

    thanks for all the help!

Share This Page