Options not allowed here

Discussion in 'Installation/Configuration' started by sushestvo, Oct 18, 2005.

  1. sushestvo

    sushestvo New Member

    One of my friends who have a web-site on my server with ISPConfig was playing with .htaccess and he got this error:
    [Sat Oct 15 03:58:30 2005] [alert] [client 217.30.xxx.xxx] /var/www/web3/web/.htaccess: Options not allowed here
    how do I fix this?
    Apache Directives in ISPConfig? If so, what do I put there?
     
  2. falko

    falko Super Moderator

    What's in the .htaccess file?
     
  3. sushestvo

    sushestvo New Member

    AddDefaultCharset windows-1251

    <IfModule mod_php4.c>
    php_flag register_globals on
    php_flag display_errors on
    </IfModule>


    #<?
    RewriteEngine On
    Options +FollowSymlinks
    RewriteBase /
    RewriteRule ^rss.xml(/?)+$ /news/rss.php
    RewriteRule ^category/([^/]*)/rss.xml(/?)+$ /news/rss.php?do=cat&category=$1
    RewriteRule ^addnews(/?)+$ /?do=addnews
    RewriteRule ^stats(/?)+$ /?do=stats
    RewriteRule ^category(/?)+$ /?do=cat
    RewriteRule ^category/([^/]*)(/?)+$ /?do=cat&category=$1
    RewriteRule ^category/([^/]*)/page/([0-9]+)(/?)+$ /?do=cat&category=$1&cstart=$2
    RewriteRule ^user(/?)+$ /?do=user
    RewriteRule ^user/([^/]*)(/?)+$ /?subaction=userinfo&user=$1
    RewriteRule ^user/([^/]*)/page/([0-9]+)(/?)+$ /?subaction=userinfo&user=$1&cstart=$2
    RewriteRule ^newposts(/?)+$ /?subaction=newposts
    RewriteRule ^newposts/page/([0-9]+)(/?)+$ /?subaction=newposts&cstart=$1
    RewriteRule ^page(/?)+$ /?cstart=0
    RewriteRule ^page/(.*)$ /?cstart=$1
    RewriteRule ^([0-9]{4})/([0-9]{2})/([0-9]{2})/page,([0-9]+),(.*).html(/?)+$ /?subaction=showcomments&year=$1&month=$2&day=$3&news_page=$4&news_name=$5
    RewriteRule ^([0-9]{4})/([0-9]{2})/([0-9]{2})/print:page,([0-9]+),(.*).html(/?)+$ /news/print.php?subaction=showcomments&year=$1&month=$2&day=$3&news_page=$4&news_name=$5
    RewriteRule ^([0-9]{4})/([0-9]{2})/([0-9]{2})/(.*).html(/?)+$ /?subaction=showcomments&year=$1&month=$2&day=$3&news_name=$4
    RewriteRule ^([0-9]{4})/([0-9]{2})/([0-9]{2})(/?)+$ /?year=$1&month=$2&day=$3
    RewriteRule ^([0-9]{4})/([0-9]{2})/([0-9]{2})/page/([0-9]+)(/?)+$ /?year=$1&month=$2&day=$3&cstart=$4
    RewriteRule ^([0-9]{4})/([0-9]{2})(/?)+$ /?year=$1&month=$2
    RewriteRule ^([0-9]{4})/([0-9]{2})/page/([0-9]+)(/?)+$ /?year=$1&month=$2&cstart=$3
    RewriteRule ^([0-9]{4})(/?)+$ /?year=$1
    RewriteRule ^([0-9]{4})/page/([0-9]+)(/?)+$ /?year=$1&cstart=$2
    RewriteRule ^static/(.*).html(/?)+$ /?do=static&page=$1
    RewriteRule ^favorites(/?)+$ /?do=favorites
    RewriteRule ^favorites/page/([0-9]+)(/?)+$ /?do=favorites&cstart=$1
    #?>


    That's inside his .htaccess (I think it's mod-rewrite)
    but how do I fix that? :(
     
  4. falko

    falko Super Moderator

    In your httpd.conf, towards the end, you find something similar to this:

    Code:
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    Replace
    Code:
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    with
    Code:
    AllowOverride All
    , restart Apache and try again.
     

Share This Page