Options +Indexes

Discussion in 'Installation/Configuration' started by staff007, Jun 20, 2011.

  1. staff007

    staff007 New Member

    Hello,

    in .htaccess added instruction for directory listening, but get error

    Code:
    Directory index forbidden by Options directive:
    
    Cent OS 5.6 Server
    without ispconfig i don't have problems. Now then installing ispconfig don't work Indexes

    Why ? How i can fix it ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ISPConfig version do you use?
    What exactly did you add in the .htaccess file?
     
  3. staff007

    staff007 New Member

    ISPConfig 3

    in .htaccess written

    Code:
    Options +Indexes
    
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. staff007

    staff007 New Member

    Code:
    <VirtualHost *:80>
          DocumentRoot /var/www/design.domaincom/web
      
        ServerName design.domain.com
        ServerAlias www.design.domain.com
        ServerAdmin [email protected]
    
        ErrorLog /var/log/ispconfig/httpd/design.domain.com/error.log
    
    	
        <Directory /var/www/design.domain.com/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client0/web9/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
    
        # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
            SetHandler None
        </FilesMatch>
        # mod_php enabled
        AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i [email protected]"	
        php_admin_value upload_tmp_dir /var/www/clients/client0/web9/tmp
        php_admin_value session.save_path /var/www/clients/client0/web9/tmp
    	# PHPIniDir /var/www/conf/web9
        php_admin_value open_basedir /var/www/clients/client0/web9/web:/var/www/clients/client0/web9/tmp:/var/www/design.domain.com/web:/srv/www/design.domain.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web9 client0
        </IfModule>
    
        <IfModule mod_dav_fs.c>
          # DO NOT REMOVE THE COMMENTS!
          # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
          # WEBDAV END
        </IfModule>
    
    
    </VirtualHost>
    
    
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Is your .htaccess located in /var/www/design.domain.com/web or any of its subdirectories, or is it anywhere else?
     
  7. staff007

    staff007 New Member

    in web directory, but it's don't work. Why ? without ispconfig working with ispconfig don't working.....
     
  8. falko

    falko Super Moderator ISPConfig Developer

    You have
    Code:
    AllowOverride All
    in the vhost, so it should work. Are there any errors in Apache's error log?
     
  9. staff007

    staff007 New Member

    Written in first post Apache show
    Code:
    Directory index forbidden by Options directive:
    
     

Share This Page