OpenVPN configuration / operation issue

Discussion in 'Server Operation' started by tiedyeguy64, Nov 14, 2009.

  1. tiedyeguy64

    tiedyeguy64 New Member

    I currently have a small office server running Debian Lenny, Samba 3, & dnsmasq (DNS/DHCP). All office based XP clients have access. I now need to add XP road warrior access via VPN, and have installed openvpn. (It was installed per this howto.) All appreaed to go well at both server & client ends (using my XP machine @ home for testing.)

    When I start the vpn connection, it appears to connect, I get notified that a TCP connection has been established, but then it resets & closes the socket. It waits 5 seconds, tries to reestablish, and continues in this loop.

    I have searched for the openvpn log, but cannot find it in /var/log/ or any other location.

    Any help would be much appreciated.

    myclient internal IP (at home):

    office internal network on
    myserver public IP (static):
    myserver IP (lan):
    office gateway:

    Server.conf file:
    Client.ovpn file:
    Snippet of connection window messages:
    I notice the [undef] notification, but am not sure what it relates to.

    Thanks for any tips.
  2. dipeshmehta

    dipeshmehta New Member

    If you use 'server-bridge', you should have to start and stop bridge with given scripts. In my opinion, its not necessary to use server-bridge, you may use server routing as well. Please change this line with
    push "route"
    Similarly change, 'dev tap' to 'dev tun', and appropriate changes to client config files also.

    You may please refer to It has step-by-step howto and guidance on every parameters, it would ease the things.

    Do come back here, if more clearance required.

  3. tiedyeguy64

    tiedyeguy64 New Member

    I appreciate the comments. Unfortunately, I still end up with the same issue - no connection.

    I have disabled the firewall (at both ends!) as well, and still no luck.

    My logs are showing an initial TCP connection, and then it just drops.

    In the end, though, I am in a position where I need a bridged connection - my remote hosts need to be able to see & browse the local network, and routed mode will not allow it to happen.
  4. dipeshmehta

    dipeshmehta New Member

    you still would have access to entire network with routed mode. I use routed mode of openvpn, and while I am on tour I can access all network resources of office.

  5. tiedyeguy64

    tiedyeguy64 New Member

    Hmmmm...that's interesting. According to everything I have read (which is a LOT lately!!!), bridged mode will allow browsing of the remote network, while routed mode will not - the [windows] client will not be able to see the browse list served up by Samba.

    I'm going to have to try it out, as currently I can get a successful connection from any client I have tried - but that is it. No pinging, nothing. I have tried with ALL firewalls disabled, so I know that is not the issue.

    Actually, I am beginning to think that my internal DNS is the issue stopping me now. I am using DNSMasq, and have noticed that it is not always pushing the default gateway to clients, and occasionally seems to drop the name resolution of my server (sometimes a ping by name works, other times I must use the IP to get a successful ping).

    Unfortunately, I am not sure if the installation of OpenVPN affected DNSMasq, or if there is a deeper issue with it. I am going to set up a non-production server her for testing today, as I had to get some files up for the office based clients. Any changes on that machine are now on a live server...

    Again, thanks so-o-o much for all your input. I will keep pushing away, and let you know what I find out.

Share This Page