OpenSuse 11 perfect setup with ISPConfig (needs some additions)

Discussion in 'Installation/Configuration' started by Norman, Aug 27, 2008.

  1. Norman

    Norman Member

    Ok, so I've done an install of ispconfig on an opensuse installation and have noticed a few things that need changed in perfectsetup guide:

    To install proftpd you also need package: libcap, libcap-devel
    Also comment "UseIPV6 off" or proftpd wont start since there is by default no ipv6 support in tat perfectsetup. Pretty silly that proftpd refuses to start cause ipv6 isnt available, when telling it NOT to use it ;)

    ISPconfig setup script also has one issue at compile:
    OpenSSL library fix for openssl sources.

    Go to compile_apps , unpack openssl-0.9.7m.tar.gz
    edit Configure and Makefile and change all instances of -m486 to -mtune=i486 .

    "tar -pczf openssl-0.9.7m.tar.gz openssl-0.9.7m" to repack dir, remove the unpacked directory.

    now run ./setup as normal.

    Credits to the following threads:
    SSL fix -
    Proftpd fix - opensuse
  2. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker for a review.
  3. Norman

    Norman Member

    I can confirm that version 2.2.25 still has this issue with the openSSL package.
  4. falko

    falko Super Moderator ISPConfig Developer

    It was too late to address this issue in 2.2.25. This will hopefully get fixed in a later version.
  5. Norman

    Norman Member

    Seems this issue also affects unstable/testing versions of debian where deprecated use of -m486 is replaced.
  6. falko

    falko Super Moderator ISPConfig Developer

    I've fixed this in the tutorial.

    I've installed ISPConfig on OpenSUSE 11, i386 and x86_64, and had no problems at all (i.e., I couldn't reproduce this). What processor are you using?

Share This Page