openSUSE 11.4 and Runlevel 3 error apache2

Discussion in 'Installation/Configuration' started by Salital, Jul 26, 2011.

  1. Salital

    Salital New Member

    Hi all,

    I installed the perfect server openSUSE 11.4 using your guide everything was perfect but when I tried to create the CLIENTS and a DATABASE but It doesn't work and the server was like blocked

    I reboot the server from the ssh shell but the apache2 server doen't work

    Appears at the end of starting process of the servers:

    Failed services in runlevel 3: apache2
    Skipped services in runlevel 3: cpufreq (I don't believe this is a problem)

    I tried to restart from:

    # /etc/init.d/apache2 restart

    but I receive the following asnwer

    Syntax OK
    Starting httpd2 (prefork): failed

    NOTE: At end of the installation I create a 'Reseller' and a 'User' and seems everything goes ok but I can't create a 'Clients' and after I was creating the DATABASE for the Reseller and the server suddenly goes in crash

    I thinks is a problem of database permission in the file config.inc.php in the ISPCONFIG

    AT the end of apache log error file /var/log/apache2/error_log I read:

    BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148

    I go at line 148 of the file above and I read:

    use Date::Format;

    Ok! But How can I start the apache2 again? On the forum and internet nobody have the same problem of me

    thks,

    S
     
    Last edited: Jul 26, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any other errors in Apache's error log?

    Did you see any errors during the ISPConfig installation?

    What's the output of
    Code:
    netstat -tap
    ?
     
  3. Salital

    Salital New Member

    Answer to your

    > Are there any other errors in Apache's error log?

    At first time that I start ISPCONFIG follow the error in the error log file (it is a snippet of the error.log file)

    [Sun Jul 24 19:32:35 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sun Jul 24 19:32:35 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbisuexec2) No log handling enabled - using stderr logging Created directory: /var/linet-snmp Created directory: /var/lib/net-snmp/mib_indexes
    [Sun Jul 24 19:32:36 2011] [notice] Apache/2.2.17 (Linux/SUSE) mod_ssl/2.2.17 OpenSSL/1.0.0c PHP/5.3.5 mod_fcgid/2.3.6 DAV/2 mmod_ruby/1.3.0 Ruby/1.8.7(2011-02-18) configured -- resuming normal operations [Sun Jul 24 19:33:52 2011] [notice] caught SIGTERM, shutting down [Sun Jul 24 19:33:54 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sun Jul 24 19:33:54 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Sun Jul 24 19:33:54 2011] [notice] Apache/2.2.17 (Linux/SUSE) mod_ssl/2.2.17 OpenSSL/1.0.0c PHP/5.3.5 mod_fcgid/2.3.6 DAV/2 mmod_ruby/1.3.0 Ruby/1.8.7(2011-02-18) configured -- resuming normal operations
    [Sun Jul 24 19:53:53 2011] [notice] caught SIGTERM, shutting down Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/sitte_perl/5.12.3 /usr/lib/perl5/vendor_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/5.12..3/i586-linux-thread-multi /usr/lib/perl5/5.12.3) at /usr/local/ispconfig/server/scripts/vlogger line 148. BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148.
    [Sun Jul 24 19:53:55 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Sun Jul 24 19:53:55 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/sitte_perl/5.12.3 /usr/lib/perl5/vendor_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/5.12..3/i586-linux-thread-multi /usr/lib/perl5/5.12.3) at /usr/local/ispconfig/server/scripts/vlogger line 148.

    After the crash I found the follow error (it is a snippet of the error.log file)

    [Mon Jul 25 12:25:21 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon Jul 25 12:25:21 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Mon Jul 25 13:04:19 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon Jul 25 13:04:19 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/sitte_perl/5.12.3 /usr/lib/perl5/vendor_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/5.12..3/i586-linux-thread-multi /usr/lib/perl5/5.12.3) at /usr/local/ispconfig/server/scripts/vlogger line 148.
    BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148. Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/sitte_perl/5.12.3 /usr/lib/perl5/vendor_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/5.12..3/i586-linux-thread-multi /usr/lib/perl5/5.12.3) at /usr/local/ispconfig/server/scripts/vlogger line 148.
    BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148. [Mon Jul 25 13:12:03 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon Jul 25 13:12:03 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/sitte_perl/5.12.3 /usr/lib/perl5/vendor_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/5.12..3/i586-linux-thread-multi /usr/lib/perl5/5.12.3) at /usr/local/ispconfig/server/scripts/vlogger line 148.
    BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148. [Mon Jul 25 16:37:53 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Mon Jul 25 16:37:53 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    Can't locate Date/Format.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/sitte_perl/5.12.3 /usr/lib/perl5/vendor_perl/5.12.3/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/5.12..3/i586-linux-thread-multi /usr/lib/perl5/5.12.3) at /usr/local/ispconfig/server/scripts/vlogger line 148.
    BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 148. [Tue Jul 26 09:29:18 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Tue Jul 26 09:29:18 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)

    > Did you see any errors during the ISPConfig installation?

    NO

    > What's the output of
    > Code:
    > netstat -tap


    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:ftp *:* LISTEN 1898/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LISTEN 1264/sshd
    tcp 0 0 *:smtp *:* LISTEN 1801/master
    tcp 0 0 localhost:10024 *:* LISTEN 1829/amavisd (maste
    tcp 0 0 localhost:10025 *:* LISTEN 1801/master
    tcp 0 0 *:mysql *:* LISTEN 1584/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 1698/dovecot
    tcp 0 0 localhost:dyna-access *:* LISTEN 1634/clamd
    tcp 0 0 *:sunrpc *:* LISTEN 1899/rpcbind
    tcp 0 0 *:imap *:* LISTEN 1698/dovecot
    tcp 0 0 server1.mysite.com:ssh 192.168.1.105:50163 ESTABLISHED 2002/0
    tcp 0 0 *:ftp *:* LISTEN 1898/pure-ftpd (SER
    tcp 0 0 *:ssh *:* LISTEN 1264/sshd
    tcp 0 0 *:smtp *:* LISTEN 1801/master
    tcp 0 0 *:sunrpc *:* LISTEN 1899/rpcbind
    tcp 0 0 localhost:55928 localhost:ftp TIME_WAIT -

    thanks,

    S
     
    Last edited: Jul 26, 2011
  4. falko

    falko Super Moderator ISPConfig Developer

    This is the problem - you need to install Date/Format.pm.

    Please try
    Code:
    yast2 -i perl-DateTime perl-DateTime-Format-DateParse
     
  5. Salital

    Salital New Member

    Hi Falko,

    thanks to you I figured out the problem about the DATE but continue the problem to start apache server, follow the last lines on the error file log

    [Wed Jul 27 11:09:19 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed Jul 27 11:09:19 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Wed Jul 27 11:58:01 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed Jul 27 11:58:01 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)

    any other advice to figured out the problem

    when I try to restart the server:

    /etc/init.d/apache2 restart

    I receive the follow answer thanks anyway

    Syntax OK
    Starting httpd2 (prefork) .......... failed

    thks anyway,

    S
     
    Last edited: Jul 27, 2011
  6. falko

    falko Super Moderator ISPConfig Developer

  7. Salital

    Salital New Member

    I don't find a solution I think install the last version of DEBIAN Squeeze

    thanks anyway

    S
     

Share This Page