Opensuse 11.0 cc1: error: unrecognized ...

Discussion in 'Installation/Configuration' started by fouad, Jul 11, 2008.

  1. fouad

    fouad New Member

    Opensuse 11.0
    Linux mail #1 SMP 2008-06-28 00:00:07 +0200 i686 athlon i386 GNU/Linux

    Followed this howto exactly : to 6
    All the package installation went fine until arrived at the Ispconfig setup where i get the following error:

    Configured for linux-elf.
    making all in crypto...
    make[1]: Entering directory `/root/install_ispconfig/compile_aps/openssl-0.9.7m/crypto'
    ( echo "#ifndef MK1MF_BUILD"; \
    echo ' /* auto-generated by crypto/Makefile for crypto/cversion.c */'; \
    echo ' #define PLATFORM "linux-elf"'; \
    echo " #define DATE \"`LC_ALL=C LC_TIME=C date`\""; \
    echo '#endif' ) >buildinf.h
    gcc -I. -I.. -I../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -c -o cryptlib.o cryptlib.c
    cc1: error: unrecognized command line option "-m486"
    make[1]: *** [cryptlib.o] Error 1
    make[1]: Leaving directory `/root/install_ispconfig/compile_aps/openssl-0.9.7m/crypto'
    make: *** [sub_all] Error 1
    ERROR: Could not make OpenSSL


    All new distro's use gcc4.3 and not 4.2. I gues that's where Ispconfig produces this error.
    allso the deprecated ? option "-m486" is still used ??

    Please how to solve this problem or work-around to install ISPconfig on Opensuse 11.0 ?

  2. fouad

    fouad New Member

    OPensuse 11.0 cc1 error ... Solved

    Ok, i unpacked ISPconfig again and went into install_ispconfig/compile_aps/
    unpacked openssl-0.9.7m.tar.gz, made some changes in Makefile and Configure
    where I replaced -m486 with -mtune=i486

    run setup and all went fine ;-)
  3. Zaphod

    Zaphod New Member

    please explain in detail

    Hello fouad,
    I have the same problem, trying to install ISP on a vmware.
    Can you please explain in detail, which changes you made in the Makefile and with which options you started the ./configure command.

  4. saxynet

    saxynet New Member

    zaphod... in both files configure and makefile replace all the "-m486" with "-mtune=i486". you have to do it just in package openssl-0.9.7m.tar.gz!

    it works for me 2.
  5. Zaphod

    Zaphod New Member

    didn´t work

    Hi saxynet,

    thanx for help, but unfortunately I get the error now from gcc:
    gcc -I. -I.. -I../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DOPENSSL_NO_KRB5 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -m486 -Wall -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -c -o cryptlib.o cryptlib.c
    cc1: error: unrecognized command line option "-m486"
    => seems the call is still -m486

    I could only change the Configure-File, because the only -m486-entry in the Makefile was # off topic

    But thank you anyway:eek:
  6. batkuip

    batkuip New Member

    Thanks it did the trick...

    Had replaced -m486 for -mtune=i486 (in the Makefile and Configure files) and repacked the openssl dir.

    tar -pczf openssl-0.9.7m.tar.gz openssl-0.9.7m
    Last edited: Aug 23, 2008

Share This Page