OpenSource installation tool

Discussion in 'Developers' Forum' started by grandpagenocide, May 11, 2008.

  1. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Ok, I am willing to take a crack at creating installation for multiple opensource products sort of like fantastico, but to get a jump start I am looking for the original typo3 pkg file. I am already working on an installer for Zen Cart, but think I can adapt the typo package to handle multiple programs. So if its still around can someone send me a link?
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Falko,
    Yes that one, however I downloaded the package and it is only the source installer for TYPO3 not the mods on ISPConfig. I would like to pick it apart a bit and see if I can make something like it but with a dropdown menu or something similar that will give an option of multiple software to install, since most of the work is already done I dont see a point in starting from scratch.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Till, I remember now the issue i had with this installer before,
    I installed the source package to usr/share/TYPO3 and I still get that message. I am using ISPC 2.3.4.
     
    Last edited: May 14, 2008
  6. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    ok I got the installer working by commenting out the $t3version = .... in the install.php, however itis still not working correctly. Can someone please tell me how to get this installer working the correct way? I installed the sources in /usr/share/TYPO3 and went into the db and added the path in the typo3 path section in isp_server but it does not recognize the versions or put up the radio buttons for me to click etc etc?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you download the modified typo3 sources from the author of the installer? As far as I know, you can not use the sources from typo3.org.

    For detailed questions you might have to ask the uthor of this function, I'am not that familar with this extension.
     
  8. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    Till,
    Yes I downloaded his sources. I have tried before to get it working with his installer before and ran into the same issue, when i comment out the version check it copies over everything except the typo3_src directory. Ill send him a PM. Thanks
     
  9. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    I have it working, my solution was to eliminate the variable for the version in /tools/tools/TYPO3/index.php and change it to 4.1.1
    and in /tools/tools/TYPO3/install.php to comment out the version check and change the variable to 4.1.1
    $T3version = $HTTP_POST_VARS["4.1.1"];
    // if(!is_string($T3version)) $go_api->msg($go_api->lng("No TYPO3 version was selected."));

    so now that I have followed the entire install, I will work on adding other software.
     

Share This Page