Opening phpMyAdmin directly from ISPConfig

Discussion in 'Installation/Configuration' started by zkvvoob, Mar 15, 2015.

  1. zkvvoob

    zkvvoob Member

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Frst, you should check your ispconfig services settings under System, server services. It seeems as none of the server has database support enabled. Additionally, you can set the URL to your phpmyadmin installation under System > Interface config.
     
  3. zkvvoob

    zkvvoob Member

    Well, yes, there was no tick for DB-Server in System > Server Services, so I clicked it.
    Then I went to System > Interface Main Config and for PHPMyAdmin URL I entered [SERVERNAME]/phpmyadmin - that changed nothing. I also tried entering the whole URL: https://server.site.com/phpmyadmin, but it would still return the same error message.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The url has to start with http:// or https://
     
  5. zkvvoob

    zkvvoob Member

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that should be ok.
     
  7. zkvvoob

    zkvvoob Member

    Well, all right, but clicking the DB icon in ISPConfig still leads me to a page which says No DB-Server found! :(
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Check again that the db servers have "database server" option enabled under system > server settings. The above error ca only occur if the database is on a server that does not has this option enabled.
     
  9. zkvvoob

    zkvvoob Member

    Before opening this topic, DB was not checked, but after your suggestion - it is. Have a look at the screenshots:
    https://imgur.com/a/K1K7s
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    and thats the server where this db is located and not a different server of the syme system?
     
  11. zkvvoob

    zkvvoob Member

    I have only one server.
     
  12. original_drew

    original_drew New Member

    Hi Ppls...
    I know this is old ..(5 yrs ) though I was researching for a different issue when I stumbled on zkvvoob's problem. I am using ispconfig 3.1dev ( I know ... I wanted it to be the stable release as well :) , and you told me Till, that I will be ok when I was troubleshooting a migration tool issue... anyways... I digress :) )... My links to database don't work either.. but I know why... and I'm not concerned. But in zkvvoob's first post at the top... the key is actually the port that the link was / is using... it's still 8080 instead of 8081.
    Just thought I'd point that out as that is the issue with 3.1dev as well :) I guess we can gather that not many of us use those links if it hasn't been picked up in 5yrs :)
    Lovin the product and the work you guys do :)
    Hat's off to you
    Cheers
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    You simply have to set the URL where your phpmyadmin is installed under System > Interface config, that's all. So no issue here, neither in 3.1 dev nor in any other ISPConfig 3 version :) And please do not reopen such old threads.
     

Share This Page