Openfiler 2.99 Active/Passive With Corosync, Pacemaker And DRBD (only 1 node visible)

Discussion in 'HOWTO-Related Questions' started by primula, Aug 31, 2011.

  1. primula

    primula New Member

    Hello together

    I have installed a openfiler-configuration with 2 nodes (same hw) with corosync, pacemaker and drbd using the following howto: http://www.howtoforge.com/openfiler-2.99-active-passive-with-corosync-pacemaker-and-drbd.

    On page two in section 4.1 i checked the corosync state with the command
    Code:
    crm_mon --one-shot -V
    and i get always a one-node configuration:

    Code:
    ============
    Last updated: Wed Aug 31 10:14:19 2011
    Stack: openais
    Current DC: node1 - partition WITHOUT quorum
    Version: 1.1.2-c6b59218ee949eebff30e837ff6f3824ed0ab86b
    1 Nodes configured, 2 expected votes
    0 Resources configured.
    ============
    
    Online: [ node1 ]
    
    why is the second node node2 not visible? Here is my drbd.conf:

    Code:
    # You can find an example in  /usr/share/doc/drbd.../drbd.conf.example
    include "drbd.d/global_common.conf";
    #include "drbd.d/*.res";
    resource meta {
     on node1 {
      device /dev/drbd0;
      disk /dev/sda4;
      address 192.168.225.15:7788;
      meta-disk internal;
     }
     on node2 {
      device /dev/drbd0;
      disk /dev/sda4;
      address 192.168.225.16:7788;
      meta-disk internal;
     }
    }
    
    her my corosync.conf:

    Code:
    # Please read the corosync.conf.5 manual page
    compatibility: whitetank
    totem {
            version: 2
            secauth: off
            threads: 0
            interface {
                    ringnumber: 0
                    bindnetaddr: 192.168.225.0
                    mcastaddr: 226.94.1.1
                    mcastport: 5405
                    ttl: 1
            }
    }
    logging {
            fileline: off
            to_stderr: no
            to_logfile: yes
            to_syslog: yes
            logfile: /var/log/cluster/corosync.log
            debug: off
            timestamp: on
            logger_subsys {
                    subsys: AMF
                    debug: off
            }
    }
    amf {
            mode: disabled
                    }
    
    any ideas?

    Thanks
     
  2. Mark_NL

    Mark_NL New Member

    is the interface { } part in the config on both servers exactly the same? double check please. If you have a different port or mcast address, the nodes won't see each other.
     
  3. primula

    primula New Member

    Hi mark, yes the file /etc/corosync/corosync.conf is exactly the same on both nodes.
     
  4. primula

    primula New Member

    We could found the solution, its very interesting. The used multicast adress was blocked by the cisco switch, we used another well known mcast-adress and now both nodes are visible :)
     

Share This Page