OpenDNS - Recursive

Discussion in 'General' started by alexillsley, Mar 11, 2007.

  1. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Hi,
    How can i stop recursive lookups / open dns. It looks bad:
    Code:
    ERROR: One or more of your nameservers reports that it is an open DNS server. This usually means that anyone in the world can query it for domains it is not authoritative for (it is possible that the DNS server advertises that it does recursive lookups when it does not, but that shouldn't happen). This can cause an excessive load on your DNS server. Also, it is strongly discouraged to have a DNS server be both authoritative for your domain and be recursive (even if it is not open), due to the potential for cache poisoning (with no recursion, there is no cache, and it is impossible to poison it). Also, the bad guys could use your DNS server as part of an attack, by forging their IP address. Problem record(s) are:
    I tryed adding "no recursive;" to my named.conf however that seem stop the server:confused:

    Any ideas how i can secure my dns?

    Thanks,
    Alex
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use your own dns server as e.g.dns server on your workstation too? No recursive means that you disable this functionality, this does not mean that the DNS server is stopped in general.
     
    Last edited: Mar 11, 2007
  3. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

  4. Hawker

    Hawker New Member

    That should be...

    recursion no;

    In the options section of named.conf

    You'll also need to add it to the ISPConfig named.conf.master so ISPConfig doesn't overwrite your changes.

    What you entered would cause an error in Bind and it wouldn't start.
     
  5. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    Sorry thats what i meant to say

    I added it to named.conf after the line where it said
     
  6. Hawker

    Hawker New Member

    recursion no; must go in the options section at the top of named.conf.
     

Share This Page