open_basedir driving me nuts!

Discussion in 'Installation/Configuration' started by PrfctGdess, Jul 3, 2012.

  1. PrfctGdess

    PrfctGdess New Member

    OK, am I missing something here? This is my error:

    PHP Warning: include(): open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web3/) in /var/www/clients/client1/web3/web/wp-includes/update.php on line 371, referer: http://mysite.com/wp-admin/network/upgrade.php

    Um, it sure LOOKS like web/wp-includes... is a subdirectory of the allowed path; I've tried the allowed path with both the final / and without it.

    Any ideas?! This warning is causing me issues on my Wordpress installation.
     
  2. till

    till Super Moderator

    This is most likey a problem with file permissions and not a open_basedir issue. If you changed open_basedir, please change it back.

    Then check that you selected as php mode of the website "php-fcgi" and that the suexec checkbox is enabled. Then ensure that all files and folders in the directory /var/www/clients/client1/web3 and its subdirectories are owned by the user "web3" and the group of the website.
     
  3. PrfctGdess

    PrfctGdess New Member

    Thanks for your response! Yes, I have the site set to FastCGI for the php mode (although I've tried others, too) and I have the suexec IS checked. I HAVE changed the open_basedir directory, but only because I've been trying to find a combination that works...I even tried disabling it at one point, and I tried leaving it as the base directory (including everything under it). I know all the folders and files belong to the user web3 and the website group, but still no luck. Do I need to manually change the file permissions, perhaps?
     
  4. dimas

    dimas Member

    try to disable (remove) eaccellerator, if you have it, and see if it helps
     

Share This Page