open suse 10.1 perfect setup

Discussion in 'HOWTO-Related Questions' started by Greg Parker, Sep 28, 2006.

  1. Greg Parker

    Greg Parker New Member

    hi there guys i got through the guide fine until i hit the apache bit.
    i keep getting this error after entering APACHE_MODULES="actions alias auth_basic [...] negotiation setenvif ssl suexec userdir php5 rewrite" to /etc/sysconfig/apache2

    sambaweb:/etc/postfix/ssl # /etc/init.d/apache2 start
    Starting httpd2 (prefork) Syntax error on line 11 of /etc/apache2/mod_log_config.conf:
    Invalid command 'LogFormat', perhaps misspelled or defined by a module not included in the server configuration

    The command line was:
    /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL
    failed

    How can i overcome this so i can get apache running again.
     
  2. Greg Parker

    Greg Parker New Member

    hi guys i fixed that error. now im being faced with
    Starting httpd2 (prefork) Syntax error on line 136 of /etc/apache2/httpd.conf:
    Invalid command 'TypesConfig', perhaps misspelled or defined by a module not included in the server configuration

    The command line was:
    /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL
    failed



    theres part of the config file where it is questioning it
    # associate MIME types with filename extensions
    TypesConfig /etc/mime.types
    DefaultType text/plain
    Include /etc/apache2/mod_mime-defaults.conf
     
  3. falko

    falko Super Moderator ISPConfig Developer

    I hope you didn't enter
    Code:
    APACHE_MODULES="actions alias auth_basic [B][COLOR="Red"][...][/COLOR][/B] negotiation setenvif ssl suexec userdir php5 rewrite"
    in /etc/sysconfig/apache2. [...] is just a placeholder for the other modules that were already there.
     
  4. Greg Parker

    Greg Parker New Member

    that part is fine falko. ive got that error message sorted out.
    Its to do with the mime.types line in apache config that is giving me grief.
    please refer to the very last part of my post previous to this one.
    Thanks heaps
     
  5. falko

    falko Super Moderator ISPConfig Developer

    It looks as if mod_mime is missing in your configuration. Please check if you have mime in your APACHE_MODULES line.
     
  6. Greg Parker

    Greg Parker New Member

    ok adding in mod_mime fixed that error.
    now when i try and restart apache i get the following error.
    Syntax error on line 151 of /etc/apache2/httpd.conf:
    Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration

    It looks like that everything i do to combat it just blows up :( lol
     
  7. falko

    falko Super Moderator ISPConfig Developer

    It seems you really messed up your APACHE_MODULES line. Please add access to it.
    BTW, you can find the necessary module for a directive by having a look here: http://httpd.apache.org/docs/2.0/mod/quickreference.html
    Search for the directive (e.g. Order), click on it, and on the new page search for the Module: line (e.g. Module: mod_access).
     
  8. Greg Parker

    Greg Parker New Member

    Thanks for all your help falko. Prior to your last response i copied and pasted the old module line and added in any modules i was missing. I managed to get it working that way.
     

Share This Page