Open ports and Client access

Discussion in 'Installation/Configuration' started by midcarolina, Jul 21, 2011.

  1. midcarolina

    midcarolina New Member

    Ok, I have finally gotten a website to resolve to the internet using Fedora 14 x86_64 with ISPConfig 3. Here is my problem. According to the ISP manual, my reseller clients and end user clients should be able to access their ISPConf. Control panel using my webserver name, which is:, then apply :8080 to the end. Doing this takes users to the router login. I have checked open ports for the modem. They are all fine. Also, here is a list of commands I have run (inside the network) for open ports according to what Linux sees:

    netstat -vatn
    netstat --listen
    lsof -i -n | egrep 'COMMAND|LISTEN'

    All of these resolve ports 8080 and 8081. I am stumped. If this means anything, they typically show like such:


    Thanks in advance
  2. falko

    falko Super Moderator ISPConfig Developer

    This must be a configuration problem with your router.

    Did you try this from within your LAN and from the outside? If it's working from the outside, but not from within your LAN, your router probably doesn't support loopbacks.
  3. midcarolina

    midcarolina New Member

    Hi Falko,
    It's actually just the opposite. This is how ISPConfig is accessible:

    Within the LAN, using the static address set for the server, 192.168.1.XX:8080
    Trying within the LAN, using, NOT accessible, although this IP points to in /etc/hosts

    Outside the LAN, nothing works at all. I have since encountered another problem as well with ISPConfig. No instruction that I have tried fixes this.

    I put a second website on using a dummy client account. Both domains resolve the same website. I have used every method of NameVirtualHost, configured

    Nothing works. I wish the manual were more helpful, but it really wasn't worth the purchase. Outside of the HowToForge tutorial on the install, I have seen no useful information on problem correction for ISPConfig 3.

    Thanks for all.
  4. falko

    falko Super Moderator ISPConfig Developer

    I guess it has nothing to do with ISPConfig (that's why you can't find anything in the manual).

    Did you add in your client's hosts file?

    BTW, I really don't think it's ok to say that it's not worth to spend 5 EUR for a 300 pages manual that contains many details (for example, it references *ALL* the input fields with examples) that you won't find anywhere else. Think of the time I spent to write this manual...
  5. midcarolina

    midcarolina New Member

    Hi Falko,
    I know you are right about the manual and I apologize. I suppose my frustration was misdirected. I suppose what has really made it difficult where this is concerned is that most of the manual - the important aspect of it - is Debian based and before I used your Fedora based tutorial, I was dealing with conflict after conflict.

    Last word, I didn't know there was a client host file, only /etc/hosts/ I am formatting the raid system and starting over. I will be using your tutorial, as it worked perfectly the first time. If I haven't offended you two much, can you tell me if the file for apache /etc/httpd/conf/httpd.conf needs to be adjusted before installing ISPConfig? The reason I ask is that the default file directory in this file is /var/www/html/ This duplicates the wed files. One going here and one going to the client directory set-up by ISPConfig.

    Thanks, and again, my apologies. Frustration brings out the best of me :(
  6. falko

    falko Super Moderator ISPConfig Developer

    No problem at all! :)

    Debian is the system where we do almost all of our development, and it's the distribution we recommend. We test on other distributions as well, but Debian will always be the distribution with the best support for ISPConfig 3 because it's our develpoment platform.

    If you use a Linux client, the file is /etc/hosts as well, and on Windows, it's C:/Windows/system32/drivers/etc/hosts (at least on my XP system - might be different on Vista/7).

    No, httpd.conf doesn't need any adjustments. The ISPConfig 3 installer will take care of everything.
  7. midcarolina

    midcarolina New Member

    Hi falko,

    Thanks for the response. As I said, I went ahead and did a new install. I contacted the router developer and asked if it supported loopback. They said for this router, that disabling Upnp would resolve the problem. Well, it did not resolve. Back to the same thing, takes to router login. Using the machine's static IP (LAN IP), 192.168.1.XX:8080 as before works perfectly.

    Should I get a new router? Honestly, this is an inexpensive router (Cisco). My system is pretty advanced (as advanced as I could afford). It is 3 terrabit (500gb x 6) raid 5 with 3 500gb hard disks for reserve. I am currently a reseller for another company, but all of my clients will move with me when the server is functioning correctly. What is your suggestion?

    Last note, running [[email protected]~]# ifconfig resolves this:


    UP LOOPBACK RUNNING MTU:16436 Metric:1 (lo)

    Can the mismatch in maximum transmission unit cause problems? They are vastly different.

    Thanks again Falko.

    Hindsight, I wish I would have used CentOS. (It's what I'm used to on VPS)
  8. falko

    falko Super Moderator ISPConfig Developer

    Did you change your client's hosts file so that points to 192.168.1.XX?

Share This Page