open DNS servers

Discussion in 'Installation/Configuration' started by Daisy, Dec 30, 2006.

  1. Daisy

    Daisy New Member

    After reading up on the forums about how to resolve open DNS, I added the

            allow-recursion {
    to my ispconfig named conf master and named.conf. Now what I get when I run a dns report from dnsstuff is "A timeout occurred getting the NS records from your nameservers! None of your nameservers responded fast enough." I remove the above recursion addition and the issue resolved. I also tried allow-recursion no; and got the same results. Any suggestions on this one?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you checked your syslog for errors after you added the limitation of the recursion?
  3. Daisy

    Daisy New Member

    yeah but it's not showing anything. I'm sorta confused I guess. Can you explain how ispconfig does stuff real quick? specifically DNS. So like, I've got a router with a static and then I'm nat'ing to a private that the server is on. which IP should be under server settings? it defaulted to the private. However, if I do a nslookup to the public ip, BIND shows the private IP address. That would mean it's not accessible to the outside world right? so I changed the IP's in DNS manager to the public but then no matter what domain I went to, it kept coming back to the same site. What am I doing wrong?
  4. falko

    falko Super Moderator ISPConfig Developer

    In DNS you must always use public IP addresses.

    For the Apache configuration you must use one of the IP addresses that is in the output of
  5. Daisy

    Daisy New Member

    which part is the apache configuration? is that - ISP Site> Basis>IP Address?

    Cause if so, I did that already. Left the private IP there and changed all IP's in the DNS manager to the public IP and it would only pull up one site. Where does ISPconfig put it's vhosts master so I can look and see what it's putting in there and see if I can determine the reason it's not working.
  6. till

    till Super Moderator Staff Member ISPConfig Developer


  7. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    That's if you want the sites to be publicly available. I have on my local LAN a dedicated DNS server running, serving all my local requests and systems on a network. This specific local DNS server forwards requests only if needed to outside/external DNS servers. All local clients only have this local DNS server as their primary DNS. It does make your local LAN very flexible.

    But that's only true if the sites your configuring do not have to be on the public Internet.
  8. edge

    edge Active Member Moderator

    Also.. Make sure that you add the above withtin the options { } part, and restart bind with /etc/init.d/bind9 restart
  9. Daisy

    Daisy New Member

    AH. that did the trick. Just want to say thanks to all who are helping me make this switch to linux. It's a little harder than windows but OH I feel so much safer.... :)
  10. edge

    edge Active Member Moderator

    Nothing wrong with Windows... and if you configure a linux server wrong, you will have the same problem(s) as a wrong configured windows server :-/
  11. Daisy

    Daisy New Member

    no arguments there I just got tired of paying for it.
  12. edge

    edge Active Member Moderator

    thats exactly the same reason for me.

    Have fun with your new OS!

Share This Page