Open DNS servers (update bug?) 2.1.2 > 2.2.2

Discussion in 'General' started by edge, Mar 14, 2006.

  1. edge

    edge Active Member Moderator HowtoForge Supporter

    After updating from 2.1.2 to 2.2.2, all my DNS server were 'Open DNS servers' again. When I was using 2.1.2 I added the 'fix' for this in both named.conf files!

    Looking at the named.conf in /root/ispconfig/isp/conf/named.conf.master and in /etc the
    Code:
    
    allow-recursion {
    localhost;
    };
    is missing again!

    After adding it, and restarting named, the DNS server is closed and ok :)
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Thats not a bug. ISPConfig replaces the templates with the default templates. If you want to keep custom master templates, make a backup before you update ISPConfig and merge your changes back in the new ISPConfig master templates.
     
  3. edge

    edge Active Member Moderator HowtoForge Supporter

    Okay.. it's not a bug.. but is it maybe not better to make this a default setup in the install file, or make an option in ISPconfig to enable/disable this?

    I'm sure that a lot of users who install ISPconfig, do not really want to have an 'Open DNS server'...
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    We will consider that. The problem with changing defaults is that it will break lots of installations that rely on a specific setting.
     

Share This Page