Only 1 user allowed on FTP

Discussion in 'Installation/Configuration' started by splyffen, Jul 12, 2010.

  1. splyffen

    splyffen New Member

    I have an issue with my FTP.

    I might have played around a little with the configuration due to passive ftp.

    But now when i start it all seems to work but i am only allowed to have 1 user logged in.

    This is the startup parameters of pure-ftpd-mysql when i restart it (all is done in configuration files)

    Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -P xxx.xxx.xxx.xxx -C 5 -u 1000 -A -E -O clf:/var/log/pure-ftpd/transfer.log -p 40100:40101 -D -b -c 10 -B

    What i have been reading is that the -C 5 means 5 concurrent users from same IP, but somewhere i lost the max number of clients also which should be the -c 10 (10 users)

    Please help, it is driving me nuts...
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you try both active and passive FTP?

    Is this a physical server or a virtual machine?
     
  3. splyffen

    splyffen New Member

    Its a physical server, and i havent tried active instead off passive yet but i Will tomorrow...
    I Will return to you by then.
     
  4. splyffen

    splyffen New Member

    I have now tried both passive and active mode, without changes...

    Respons: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Respons: 220-You are user number 1 of 1 allowed.
    Respons: 220-Local time is now 07:09. Server port: 21.
    Respons: 220-This is a private system - No anonymous login
    Respons: 220-IPv6 connections are also welcome on this server.
    Respons: 220 You will be disconnected after 15 minutes of inactivity.
     
  5. kerrsmith

    kerrsmith Member

    I had the same issue when I added the passive FTP configuration file.

    I found that by increasing the port range from just two ports to say ten then it allowed me to have five users connected at the same time and this was reflected in the message displayed on connection:

    Response: 220-You are user number 1 of 5 allowed

    It seemed to need two ports per user and for me this solved the issue.
     
  6. splyffen

    splyffen New Member

    thank you, thank you

    that worked like a charm, now i just have to add the ports to the firewall :)

    thank you very much :D
     

Share This Page