old phpmyadmin2 need update to phpmyadmin3

Discussion in 'General' started by phibrz, Jun 24, 2013.

  1. phibrz

    phibrz New Member

    Im using the guide:

    BUT it say on Page 5 (http://www.howtoforge.com/perfect-server-centos-6.4-x86_64-nginx-dovecot-ispconfig-3-p5)
    that "yum install phpmyadmin"
    this is an old phpmyadmin version 2.X
    "yum install phpmyadmin3" should be correct because if you run "yum update" after installation and then try to use phpmyadmin
    you get errors like:
    Deprecated: Function Eregi() Is Deprecated In /usr/share/phpmyadmin/libraries/select_lang.lib.php

    with is fixed with:

    and when this is fixed and you login you get errors like:
    /usr/share/phpmyadmin/libraries/check_user_privileges.lib.php on line 34 Deprecated: Function ereg() is deprecated in /usr/share/phpmyadmin/libraries/check_user_privileges.lib.php

    All of these errors are because its version 2.X of phpmyadmin version 3.X have these issues solved.

    So why is ISPconfig not using phpmyadmin3 and if i install it will it break the system or even work?

    RGDS Phi
  2. dclardy

    dclardy New Member

    ISPConfig can use whatever version you want to use. Your system is installing the older package because CentOS has 2.X related to that command. If you install the new version, you will see no issues.
  3. phibrz

    phibrz New Member

    Ok, so a simple yum erase phpmyadmin
    and then yum install phpmyadmin3 should work?
  4. dclardy

    dclardy New Member

    That should take care of it for you.
  5. tahunasky

    tahunasky New Member

    Or you can just download the latest version from phpmyadmin site:


    remove old version first, then:

    extract phpMyAdmin-4.0.4-english.7z dir/files and then copy directory to the opt dir on server. eg:


    then add a redirect to apache. Create a file called:


    or on centos it might be:


    add the following to phpmyadmin.conf:

    Alias /phpmyadmin /opt/phpMyAdmin-4.0.4
    Alias /phpMyAdmin /opt/phpMyAdmin-4.0.4
    Alias /pma /opt/phpMyAdmin-4.0.4

    <Directory /opt/phpMyAdmin-4.0.4>
    Options +FollowSymLinks
    Order allow,deny
    allow from all

    If you want ssl add the following also:

    RewriteEngine on
    RewriteCond %{HTTPS} !=on
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

    Restart apache or reboot server:

    /etc/init.d/apache restart

    or centos might be..

    /etc/init.d/httpd restart

    and you should be able to access from:
  6. phibrz

    phibrz New Member

    Removed the old version 2 of phpmyadmin
    and did yum update
    then yum install phpMyAdmin
    now i got phpMyAdmin-4.0.4-1.el6.remi.noarch

    BUT since im using the guide with nginx on centos instead of apache (http://www.howtoforge.com/perfect-server-centos-6.4-x86_64-nginx-dovecot-ispconfig-3-p5)
    the alias that is in /etc/httpd/conf.d/phpMyAdmin.conf
    Alias /phpMyAdmin /usr/share/phpMyAdmin
    Alias /phpmyadmin /usr/share/phpMyAdmin
    don´t work for me and now i just get
    403 Forbidden

    when i try to access
    or http://myhostname.com:8081/phpMyAdmin/

    been trying for several hours to find the solution, so if anyone can help i will be happy.
  7. phibrz

    phibrz New Member

    anyone got a solution for the 403 error i got?

    it´s strange cause i renamed the old phpmyamin folder that contained only config.inc.php.rpmsave to phpmyadmin_old
    and then renamed the folder that phpMyAdmin-4.0.4-1.el6.remi.noarch created /usr/share/phpMyAdmin to /usr/share/phpmyadmin and it worked.

    i belive i´ve read it checks both folders in /usr/share/php* or?
    Last edited: Jul 22, 2013

Share This Page