Old PHP (IspConfig 3.1 encoded in ioncube for 5.6) not runnin in php 7.3

Discussion in 'Installation/Configuration' started by abalg, Apr 30, 2019.

  1. abalg

    abalg New Member

    How can I get the ISPConfig functionality back now after upgrading to PHP 7.3 (in debian Jessie ) now that the Ioncube Loader cannot decrypt parts of ISPconfig anymore ?
    PHP 5.6 is also still installed - how to make the CP run under PHP 5.6 would also be an option (though not my favourite)
    after the Updated to PHP 7.3 + download of the latest ioncube loader I just get:

    PHP Fatal error: The file /usr/local/ispconfig/interface/lib/classes/idn/idna_convert.class.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.

    Can you tell me how to fix this?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The file /usr/local/ispconfig/interface/lib/classes/idn/idna_convert.class.php can be removed, it is part of the Migration Tool and not ISPConfig. When you use the Migration Tool the next time, it will install a class that is encoded for the new PHP version if required.

    But besides that, I highly recommend switching the default PHP version back to the version that comes with your OS, if you don't do that, other software might fail and the next ISPConfig Update will probably fail too.
     
  3. abalg

    abalg New Member

    Thank you very much - that did the trick, as far as I can see - everything works as a charm.

    Just as an information
    In fact those php7.3 packages are from packages.sury.org but seem to be maintained as backports by the debian PHP - package maintainers themselves. So far these packages are the best option and well maintained regarding fixes and updates as I've experienced until now - These are meant to be installed in parallel with the default OS stuff, not to replace it - much easier to do and maintain than your documented variant according to the HowTo's which propose to compile it myself from my point of view.

    ... Actually running ispconfig_update.sh and everything else (from 3.1.3 to 3.1.3p1) worked flawlessly after installing these packages and modules (in parallel!) (7.0-7.3) so far as well ... But for some reason that I did not really investigate thoroughly, apache2 currently seems to use the 7.3 engine as default php engine to run the CP in my setup - which apparently works fine as I see nevertheless - all other clients/webs keept running the previously defined defaults.

    So I'll probably stay with this setup for now as many newer software requires updated packages and can recommend that setup from my current experience until now. (running previous releases since almost 1.5 years from there now) - Of course it would be time to setup/update the base OS ;-)

    Cheers
    Andreas

    apt-cache show php7.3
    Package: php7.3
    Version: 7.3.4-1+0~20190412071213.37+jessie~1.gbpabc171
    Built-For-Profiles: nocheck
    Architecture: all
    Maintainer: Debian PHP Maintainers <[email protected]>
    Installed-Size: 91
    Depends: libapache2-mod-php7.3 | php7.3-fpm | php7.3-cgi, php7.3-common
    Provides: php
    Priority: optional
    Section: php
    Filename: pool/main/p/php7.3/php7.3_7.3.4-1+0~20190412071213.37+jessie~1.gbpabc171_all.deb
    Size: 35124
    SHA256: 520b949998153f0a618a6ecbfec7e10dc99ebaa6579ae4a74998864c2d36c44c
    SHA1: 00e9b70086e0efea00ea1792497fdbf35ce5d28a
    MD5sum: 92502ae32080d819820999e01908ab97
    Description: server-side, HTML-embedded scripting language (metapackage)
    This package is a metapackage that, when installed, guarantees that you
    have at least one of the four server-side versions of the PHP interpreter
    installed. Removing this package won't remove PHP from your system, however
    it may remove other packages that depend on this one.
    .
    PHP (recursive acronym for PHP: Hypertext Preprocessor) is a widely-used
    open source general-purpose scripting language that is especially suited
    for web development and can be embedded into HTML.
    Description-md5: 86488d7a405bdcbac9ece7c307f30abb
     
    ahrasis likes this.
  4. ahrasis

    ahrasis Well-Known Member

    I basically use the same approach to ensure all my php (5.6, 7.1, 7.2, 7.3) is always current and it did change my server default from php7.2 to 7.3 but I did not revert my Ubuntu 18.04 server php back.

    So far I did not face any problems with any internal applications that are using php, perhaps because Ubuntu 18.04 itself come with php7.2 and php.7.3 is mostly the same.

    I cannot say the same for other distro that come with default php lower than 7.2 but I do think their best choice is as advise by @till that is to revert back to their distro default php.
     

Share This Page