Okay...don't know how to download ispconfig...:(

Discussion in 'Installation/Configuration' started by happz, Feb 21, 2008.

  1. happz

    happz Member

    I’m sorry folks. I’m a little reluctant to ask but i am going to have to do it. I followed the howtoforge from start to end for centos 5 perfect server. man i was having fun.....then the last step was to install ispconfig...and that is when it was over.

    Now i have a server with no gui interface and I’m lost. Now with just a command line what do i do to get ispconfig installed....i just can't find anything that tells me directly.

    I need something like.. type at the command line..xxxxxxxxxxxx what ever. Yes, it is true...just picked up Linux a few weeks ago and I’m taking on more than i should but I’m trying to have fun...

    Anyone that wants to deal with a newbie please do...thanks all.
  2. shakey_1

    shakey_1 New Member

    I do not use ISPConfig, so just by looking at their installation instructions, this should get you started.

    cd /tmp/
    "wget http://superb-east.dl.sourceforge.net/sourceforge/ispconfig/ISPConfig-2.2.21.tar.gz" - Remove the quotes
    tar xvfz ISPConfig-2.2.21.tar.gz
    cd install_ispconfig

    From there it appears that you just have to answer some questions as the installation progresses. If you go here and scroll about half-way down the page, there are some pretty decent looking instructions on how to install it. Hope that it helps.
    Last edited: Feb 21, 2008
  3. happz

    happz Member

    Thanks! I tried that and here is my message...

    ERROR: Ihr Betriebssystem wird nicht unterstützt! / Your operating system is not supported! / Votre systeme d'exploitation n'est pas supporté!
    [[email protected] install_ispconfig]# ERROR: Ihr Betriebssystem wird nicht unterstützt! / Your operating system is not supported! / Votre systeme d'exploitation n'est pas supporté

    Any idea?
  4. shakey_1

    shakey_1 New Member

    I found this thread where someone was having the same issue - http://www.how2forge.org/forums/showthread.php?t=6693

    I don't have CentOS installed at the moment, but Google shows it at /etc/redhat-release (if it is in the same location as Red Hat). Might try that, otherwise you might have to wait and see if someone who runs ISPConfig comes along with a beter suggestion. Sorry.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux distribution do you use? Centos5 is recognized and supported by ISPConfig 2.2.21.
  6. happz

    happz Member

    I am using centos 5 (final)

    Not sure if this helps. Also, not to get off the subject but do i really have to have me server in the mode (non-GUI)? if it is not really required is there a way i can get back to GUI (xwindow i think is what it's called) so that i can get around quicker (since i am a very newbie).....


  7. falko

    falko Super Moderator ISPConfig Developer

    I don't recommend to run a desktop on a server. It's an additional security risk and increases the load.
  8. happz

    happz Member

    It was posted that someone else received the same error

    I will leave the config the way it is but.......

    I reviewed the post where someone had a similar error as me ...in refer. to wrong os version. it was told to them that if they changed their version number it would resolve which seemed to fix their issue. Can someone tell me how to change my os version x.x so that this new install will work for me?

    thanks all!!!!
  9. happz

    happz Member

    Update! Re-installed from start to finish....new results

    Okay...the error i was receiving was due to improper installation. After slowing down and make sure i was following each step of the perfect server i now have the installation going for ISPConfig.

    My next two questions are general:

    1. I am at the question which is asking for the email address for when a customer may need to ask a question...:

    should i put my personal email address in this space? i.e. [email protected]

    2. my ip is a private ip i.e. 192.x.x.x and i use cable modem business class. The server is at work on the cable connection. How will i access it from home with ISPConfig...

    be easy on me...i'm very new as i have said...:)

    Last edited: Feb 23, 2008
  10. falko

    falko Super Moderator ISPConfig Developer

    Yes, you can do that.

    For the web sites you create in ISPConfig, you must use your private IP address. The DNS records for your domains must point to your router'S public IP address, and your router must forward all needed ports (e.g. 21, 22, 25, 80, 81, 110, 443) to your ISPConfig server.
  11. happz

    happz Member

    clear step by step and what might i run into for problems...

    Just to make sure I understand I want to be specific.

    I'm using a 192.x.x.x for my server's IP and the DNS i received from the cablemode showed 24.x.x.x so that is what i used for my setting as my dns.

    Cable modem Business class plugged into linksys router to my office.

    I will purchase domain via godadXX.com and then what to make this happen?

    Most important is what are real world problems i will face from your experience?

    thank you.
  12. falko

    falko Super Moderator ISPConfig Developer

    As the nameserver you should use the onesgiven to you by your ISP, not your router's public IP address.

    In the GoDaddy interface you can manage the DNS records for your domain. Create A records for yourdomain.com and www.yourdomain.com that point to your router's public IP address.
  13. happz

    happz Member

    The IPs 24.x.x.x are the ISP's DNS ips.

    Define my routers public IP- is that the static ip the ISP just gave me which they tied to my linksys routers mac address?

    The domain i am using is friscoface.com as when i answered the questions at the end of the configuration of ispconfig i put:
    Domain name: friscoface.com
    So i logged on to godaddy and went to name servers for friscoface.com and tried many options to make it where i can log onto ispcong. I added ns1.friscoface.com with ip of my routers public static of 72.24.x.x and I add also the IP of the ISPs DNS which is 24.x.x.x that was a no go. I then added just the name server to cableone which is ns1.cableone.net and ns2.cableone.net, no go there either.
    I did port forwarding of all that are required yet, i am unable to get a successful 1st time logon to ispconfig.

    When i first set up the server following the "perfect server" formula i did this:
    Hostname: redriver.linux.com
    static IP of
    During the rest of the instructions i used redriver.linux.com when prompted for hostname as in the example.
    I completed that tutorial and i installed ispconfig as well with what is described above.
    If anyone out there knows where i am going wrong, please help.

    Last edited: Feb 26, 2008
  14. falko

    falko Super Moderator ISPConfig Developer


    Why did you change the nameservers? You can use the default ones from GoDaddy.
  15. happz

    happz Member

    if i leave godaddy as it was then....

    where does this info go?


  16. falko

    falko Super Moderator ISPConfig Developer

    I don't know the GoDaddy interface.

Share This Page